Closed Bug 819691 Opened 12 years ago Closed 12 years ago

Alert in Drag and Drop causes Firefox to stop handling Drag and Drop anywhere

Categories

(Firefox :: Untriaged, defect)

10 Branch
x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 100180

People

(Reporter: Hujnak.Ondrej, Unassigned)

Details

(Keywords: regression, reproducible, Whiteboard: [DUPEME?])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20121119145849

Steps to reproduce:

Run attached html file. Drag div multiple times.


Actual results:

First time everything works. Second time dragend event does not fire and than Drag and Drop features in every tab/window are disabled until restart.


Expected results:

Fire dragstart and dragend events every time (thus showing alert every time there is dragend). Do NOT affect other tabs/windows.
Attachment #690111 - Attachment description: Website causing faulty behaviour → Testcase (HTML page causing faulty behaviour)
Attachment #690111 - Attachment mime type: text/plain → text/html
Reproduced with 2012-12-10-03-07-47-mozilla-central-firefox-20.0a1.en-US.linux-x86_64.  Dragging becomes impossible also for tabs in the tab bar, but not in Panorama.

WFM: 2012-05-02-03-05-05-mozilla-central-firefox-15.0a1.en-US.linux-x86_64
bug: 2012-05-03-03-05-12-ru-x86_64

Regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-05-02&enddate=2012-05-03+03%3A05

bug 805671?
OS: Windows XP → All
Whiteboard: [DUPEME?]
It looks like it's the alert() call that causes the problem.  Replacing it with:
  document.body.appendChild(document.createTextNode('Block drag. '))
seems to work ok.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: