Closed Bug 819751 Opened 7 years ago Closed 7 years ago

Unable to move the map on Openstreetmap website

Categories

(Core :: DOM: Core & HTML, defect)

20 Branch
x86_64
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox20 - ---

People

(Reporter: mathieu.marquer, Assigned: bzbarsky)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20121208 Firefox/20.0
Build ID: 20121208030937

Steps to reproduce:

Going on Openstreetmap.org, trying to move the displayed map


Actual results:

The map doesn't move, only the tile selected moves with transparency (like if I selected an image on a website)


Expected results:

The map should be moving. This bug appeared no more than 3 or 4 days ago.
Confirmed using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121208 Firefox/20.0 ID:20121208030937

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20121208 Firefox/19.0 ID:20121208042017 is okay.
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/739f20de3c1e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121207 Firefox/20.0 ID:20121207030741
Bad:
http://hg.mozilla.org/mozilla-central/rev/8432562db685
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121207 Firefox/20.0 ID:20121207061451
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=739f20de3c1e&tochange=8432562db685


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e42b1de74b4d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121206 Firefox/20.0 ID:20121206122352
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/8a0c82cf76ab
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121206 Firefox/20.0 ID:20121206132551
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e42b1de74b4d&tochange=8a0c82cf76ab

Suspected:
d5179738abfe	Peter Van der Beken — Fix for bug 818219 (Replace HTMLElement quickstubs with new binding methods). r=bz.
Blocks: 818219
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM
Ever confirmed: true
Product: Firefox → Core
The problem is this:

  [10:02:33.437] "ontouchstart" in HTMLElement.prototype
  [10:02:33.445] true

plus whatever hackery openstreetmap is doing when it thinks you have touch events.

My profile doesn't seem to have a dom.w3c_touch_events.expose pref set, so it looks like we never called nsGenericHTMLElement::PrefEnabled.  Which makes sense; why would we have done that in the quickstub setup?

Peter, I think we should just comment out the touch even properties from the WebIDL until we're using the actual WebIDL prototype.  The other option is to get quickstubs to call PrefEnabled() here, but that's likely more work.
Go r=peterv on comment 3 on irc, landed https://hg.mozilla.org/integration/mozilla-inbound/rev/81c3ce1dde6f
Assignee: nobody → bzbarsky
Flags: in-testsuite?
https://hg.mozilla.org/mozilla-central/rev/81c3ce1dde6f
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Untracking the nomination flag as this is fixed.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.