Invalid URL's in Embed Code

RESOLVED INVALID

Status

Firefox Affiliates Graveyard
affiliates.mozilla.org banners
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: bkerensa, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121129152329

Steps to reproduce:

Tried to use Firefox Affiliates


Actual results:

Got provided:
<a href="//affiliates.mozilla.org/link/banner/7711"><img src="//affiliates.mozilla.org/media/uploads/banners/5b88e17728a2c52e43bc10d378f98cd5fd667fda.png" alt="WebFWD" /></a>


Expected results:

Provided:
<a href="http://affiliates.mozilla.org/link/banner/7711"><img src="http://affiliates.mozilla.org/media/uploads/banners/5b88e17728a2c52e43bc10d378f98cd5fd667fda.png" alt="WebFWD" /></a>
(Reporter)

Comment 1

5 years ago
Adding Diane since this impacts WebFWD's banners
Those links are intentional. They are protocol-relative links that allow the image and link to use http or https depending on the protocol of the page they are embedded on.

If they are not functioning, please reopen this bug. Note that he links will not work properly if you are viewing a page locally (using the file:// protocol in the URL).

Thanks for the report!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.