Marionette not properly starting tests and switching to frame (regression: 12/09)

VERIFIED FIXED

Status

Testing
Marionette
--
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: automatedtester)

Tracking

({regression, reproducible})

unspecified
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, b2g18 fixed)

Details

(Reporter)

Description

5 years ago
I/Gecko   (  109): 1355096371526	Marionette	INFO	could not load listener into content for page: chrome://browser/content/shell.xul
I/Gecko   (  109): 1355096371536	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","value":"6-b2g"}, undefined, {dad8abbc-b7ab-4d51-a2dc-b385d561c1d0}
I/Gecko   (  109): 1355096371537	Marionette	WARN	got a response with no command_id
I/Gecko   (  109): 1355096371546	Marionette	DEBUG	Got request: setTestName, data: {"to":"conn5.marionette1","session":"6-b2g","type":"setTestName","value":"test_music.py TestMusic.test_select_album_play"}, id: {c40064b5-f3f8-4725-b7ae-c698cbd66151}
I/Gecko   (  109): 1355096371548	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","ok":true}, {c40064b5-f3f8-4725-b7ae-c698cbd66151}, {c40064b5-f3f8-4725-b7ae-c698cbd66151}
I/Gecko   (  109): 1355096371558	Marionette	DEBUG	Got request: execute, data: {"to":"conn5.marionette1","specialPowers":false,"session":"6-b2g","newSandbox":true,"args":[],"type":"executeScript","value":"log('TEST-START: /Users/AaronMT/Desktop/gaia-ui-tests/gaiatest/tests/test_music.py:test_select_album_play')"}, id: {ef4633b3-d7f2-4177-9ea3-e595d16b5616}
I/Gecko   (  109): MARIONETTE LOG: INFO: TEST-START: /Users/AaronMT/Desktop/gaia-ui-tests/gaiatest/tests/test_music.py:test_select_album_play
I/Gecko   (  109): 1355096371579	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","value":null}, {ef4633b3-d7f2-4177-9ea3-e595d16b5616}, {ef4633b3-d7f2-4177-9ea3-e595d16b5616}
I/Gecko   (  109): 1355096371595	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","ok":true}, {364bb383-57cf-4df2-918f-6ada87a3e997}, {364bb383-57cf-4df2-918f-6ada87a3e997}
I/Gecko   (  109): 1355096371601	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","ok":true}, {695e7596-3909-4207-9f9c-d2ee19182748}, {695e7596-3909-4207-9f9c-d2ee19182748}
I/Gecko   (  109): 1355096371610	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","ok":true}, {0b32e3df-1872-4905-8cc8-21435555f0a3}, {0b32e3df-1872-4905-8cc8-21435555f0a3}
I/Gecko   (  109): 1355096371622	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","ok":true}, {4c50dc8f-1ced-4bd6-a229-766c4b25ac8e}, {4c50dc8f-1ced-4bd6-a229-766c4b25ac8e}
I/Gecko   (  109): 1355096371632	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","ok":true}, {0f344710-c87c-4abe-aa7c-af72e917e436}, {0f344710-c87c-4abe-aa7c-af72e917e436}
I/Gecko   (  109): 1355096371640	Marionette	INFO	sendToClient: {"from":"conn5.marionette1","ok":true}, {17f6b9c3-b001-47c6-8923-74b744522b03}, {17f6b9c3-b001-47c6-8923-74b744522b03}
I/Gecko   (  109): 1355096371645	Marionette	DEBUG	Got request: switchToFrame, data: {"to":"conn5.marionette1","session":"6-b2g","type":"switchToFrame","value":null}, id: {941bf7c7-5184-4db9-b705-66ec0599f5fe}

---------------------------------------

  File "/Library/Python/2.7/site-packages/marionette_client-0.5.10-py2.7.egg/marionette/marionette.py", line 367, in switch_to_frame
    response = self._send_message('switchToFrame', 'ok', value=frame)
  File "/Library/Python/2.7/site-packages/marionette_client-0.5.10-py2.7.egg/marionette/marionette.py", line 201, in _send_message
    raise TimeoutException(message='socket.timeout', status=ErrorCodes.TIMEOUT, stacktrace=None)
TEST-UNEXPECTED-FAIL | test_music.py TestMusic.test_select_album_play | TimeoutException: socket.timeout

---------------------------------------

Quite possibly a Gaia regression. I have just flashed unagi-eng (12/09) to my device and it looks like Marionette is not initiating the test-run process beyond the switchToFrame request.

The only suspicious message in my marionette.log is 

1355096371526	Marionette	INFO	could not load listener into content for page: chrome://browser/content/shell.xul
(Assignee)

Comment 1

5 years ago
Test to use, from the log is https://github.com/mozilla/gaia-ui-tests/blob/master/gaiatest/tests/test_music.py#L31
This appears to be affecting all tests on CI. Raising to blocker.
Severity: normal → blocker
blocking-basecamp: --- → ?

Updated

5 years ago
Whiteboard: [qa-automation-blocked]
(Assignee)

Updated

5 years ago
Assignee: nobody → dburns
There weren't any changes made to Marionette code on Dec 9, the most recent change was bug 754220 on Dec 7, which would have been in Dec 8th's build.
(Assignee)

Comment 4

5 years ago
I can't seem to replicate on the emulator and having redo my otoro repo :(

have also chased up my new unagi.
Blocks: 801898
(Assignee)

Comment 5

5 years ago
I can't seem to reproduce this on my otoro from a clean build. Can someone please see if this is still an issue on a unagi. 

I see the CI is looking healthier. Are the following builds from Friday's image?

http://qa-selenium.mv.mozilla.com:8080/job/b2g.gaia.unagi/471/
http://qa-selenium.mv.mozilla.com:8080/job/b2g.gaia.unagi/472/
Flags: needinfo?(stephen.donner)
(In reply to David Burns :automatedtester from comment #5)
> I can't seem to reproduce this on my otoro from a clean build. Can someone
> please see if this is still an issue on a unagi. 
> 
> I see the CI is looking healthier. Are the following builds from Friday's
> image?
> 
> http://qa-selenium.mv.mozilla.com:8080/job/b2g.gaia.unagi/471/
> http://qa-selenium.mv.mozilla.com:8080/job/b2g.gaia.unagi/472/

That's a build from the 7th, as we were trying to temporarily work around the problem.
Flags: needinfo?(stephen.donner)
(Reporter)

Comment 7

5 years ago
Noting, same story with today's 12/11 unagi-eng build.
This is a blocker if it's stopping all Marionette tests from running in CI.  We were confused, though, since it seems that they're running on tbpl.
blocking-basecamp: ? → +

Comment 9

5 years ago
(In reply to Andrew Overholt [:overholt] from comment #8)
> This is a blocker if it's stopping all Marionette tests from running in CI. 
> We were confused, though, since it seems that they're running on tbpl.

This is on unagi specifically. What you're seeing on TBPL are emulator based tests.

We don't have enough unagi devices to expose them to the volume of per-checkin tests so that you could see them on TBPL (among many other reasons why they can't appear there, some of which we'll address in early 2013).
I can reproduce this on my unagi with a beta build.  It's a very odd problem; none of the scripts that Marionette executes to unlock the lock screen, launch an app, etc, have any effect.  They don't produce errors, they just seem to do...nothing.  I'm investigating.
I've confirmed this does not occur on inbound.  The gaia commit is not a factor.  Maybe there was a bad merge to mozilla-beta?
It looks like this was due to a bad merge on mozilla-beta, which I've fixed in https://hg.mozilla.org/releases/mozilla-beta/rev/99207d3a7041.  Please test with the Dec 12 build.
It turns out we are not running desktop Marionette tests on mozilla-beta, which would have caught this.  I'll file a bug for adding those.

Updated

5 years ago
Duplicate of this bug: 820668
(Reporter)

Comment 15

5 years ago
Verified Fixed,

All is good with today's build, 12/12
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [qa-automation-blocked] → [qa-automation-blocked][status-b2g18:fixed]
status-firefox18: --- → fixed
status-b2g18: --- → fixed
Whiteboard: [qa-automation-blocked][status-b2g18:fixed] → [qa-automation-blocked]
Whiteboard: [qa-automation-blocked]
You need to log in before you can comment on or make changes to this bug.