MVO carrier name not properly displayed

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia::System
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dpalomino, Assigned: kk1fff)

Tracking

unspecified
B2G C3 (12dec-1jan)
x86_64
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

5 years ago
Hi, 

We've been re-checking the visualization of MVO carrier name with:

Gaia: 3ad4e525a43a44b3c6eb905304fc0648ca5fd9b8
Gecko: 74bff8c0506e6ff91666095b432fbc6aed9621fe

Dec 6th build (tested with Unagi), and a SIM from tuenti (MVO from Telefónica Spain). 

This is not properly handled, as it seems to be always showing the name according MCC/MNC broadcasted, and not according SIM EF_SPF file. Instead of "tuenti" is always shown "movistar". 

This could be related with bugs: 
https://bugzilla.mozilla.org/show_bug.cgi?id=793111
https://bugzilla.mozilla.org/show_bug.cgi?id=815595

That are supposed to be fixed. 

Issue marked as bb+ candidate. 

Thanks!
David

PS: I've used same cc list as previously listed related bugs
(In reply to David Palomino [:dpv] from comment #0)
> PS: I've used same cc list as previously listed related bugs

Thanks. You can just set the dependency on that. 

Patrick, what's the step to move forward? I don't think we recreate the same condition in Taipei :-/
Flags: needinfo?(pwang)
Would you help to test again with this.DEBUG_ALL = true in ril_consts.js and upload the log, so we can figure out how to fix this? Thanks.
Flags: needinfo?(pwang)
(Reporter)

Comment 3

5 years ago
Adding dependencies...
Depends on: 793111, 815595
could this be somehow related to bug 798000
Hi Patrick, is this the same issue as bug 798000?
Flags: needinfo?(pwang)
(In reply to Naoki Hirata :nhirata from comment #5)
> Hi Patrick, is this the same issue as bug 798000?

I don't think that they are related. Bug 798000 implements EF_PNN and EF_OPL, which provide a way to change displayed network name. But this bug looks like ril_worker didn't provide correct display conditions, so the displayed carrier name is network name instead of SPN.
Flags: needinfo?(pwang)
Triage: Daniel or David, does this effect any of the initial target markets or is it only reproduceable in Spain?
Flags: needinfo?(dcoloma)
It might affect any market, we cannot control the SIM Card user is going to insert the device and we need to show the operator that is providing the service to the customer, this could be super-confusing to them
Flags: needinfo?(dcoloma)
Marking blocking as this could cause certification problems, Patryk please re-assign if you're not the right person.
Assignee: nobody → pwang
blocking-basecamp: ? → +
(Reporter)

Updated

5 years ago
Blocks: 819528
Hi David, I cannot reproduce this in Taipei with SIM cards I have. Could you provide the log of your testing device? Setting this.DEBUG_ALL = true in dom/system/gonk/ril_consts.js can print the RIL log. It would be very helpful. Thanks.
Flags: needinfo?(dpv)
(Reporter)

Comment 11

5 years ago
Hi Patrick, 

Yes, we'd try to get the logs and upload them, we'll let you know. 

Thx!
David
Flags: needinfo?(dpv)
Add C3 milestone so it doesn't get missed in C3 query
Target Milestone: --- → B2G C3 (12dec-1jan)
(Reporter)

Comment 13

5 years ago
Hi, 

I've just restested it with unagi and build 20121213075759, and now it's working fine. 

Tested with Tuenti's SIM card (MVO from Telefonica Spain). 

Bug marked as RESOLVED/FIXED. 

Thanks!
David
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.