mac copy and paste commands not functional

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Rachel Fedde, Assigned: Peter Trudelle)

Tracking

({regression})

Trunk
PowerPC
Mac System 9.x
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 (Macintosh; U; PPC)
BuildID:    20001051504

If you highlight the URL and use apple-C for copy and then try to paste into 
another app, it doesn't work.  If you click and hold on a link to access the menu 
and select "copy link location" and try to copy that into another app or into the 
top location bar in N6.1, it doesn't work.  If you copy a link from another 
browser such as Netscape 4.5 it does not paste into the 6.1 build.

Reproducible: Sometimes
Steps to Reproduce:
1. load a page
2. highlight URL in top location bar
3. hit applekey and "C" for copy command
4. hit applekey and "V" for paste command in either Netscape 6.1 URL location bar 
or other application (IE, older Netscape browsers, MS  Word, etc)

1. Copy URL from a different browser (IE, older Netscape browsers, etc) using 
apple key and "C"  
2. Switch to Netscape 6.1 
3. Try to paste using apple key and "V"

Actual Results:  In first set, where you are trying to copy from N6.1 to another 
app, computer pastes in whatever was last in your clipboard, not URL you tried to 
copy from N6.1.

In second instance, where you are trying to copy to N6.1 from another browser, it 
doesn't paste in anything at all.



Expected Results:  Should be able to copy and paste links from/to any other 
application

The very first time I tried to copy into N6.1 worked but not subsequently.  This 
happened again when I quit out and restarted the 6.1 build.

Comment 1

17 years ago
bad.
Assignee: asa → trudelle
Component: Browser-General → XP Toolkit/Widgets
Keywords: regression
QA Contact: doronr → aegis
wfm with commercial build from 5/17/01
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 3

17 years ago
In the latest Moz builds, the "Copy Link Location" and "Copy Image Location" 
contextual menu items don't work at all. But copy/paste of general text in the 
browser works in the trunk builds.

Comment 4

17 years ago
Copy Link, Copy Image is/was bug 80059

Comment 5

17 years ago
May God have mercy on us all. The 212 bug spam-o-rama is Now!
QA Contact: aegis → jrgm
You need to log in before you can comment on or make changes to this bug.