gaia multilocale target doesn't translate FTU properly

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: bhearsum, Assigned: gandalf)

Tracking

unspecified
B2G C3 (12dec-1jan)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: dupme [target:12/21])

(Reporter)

Description

6 years ago
Willyaranda reported in #l10n today that the RelEng provided builds (which use the multilocale target in Gaia's Makefile), don't have a translated FTU. However, he said that when building himself with "make production" (which eventually calls the "profile" target), he does have a translated FTU.

Sounds to me like the multilocale logic in Gaia's build system has a bit somewhere. Pretty sure this a basecamp blocker, but I don't think it's a C2 one, since it's the only FTU affected.

Comment 1

6 years ago
Willyaranda says that he can reproduce on desktop, so knowing what the error console says might be useful.

Updated

6 years ago
Component: Gaia → Gaia::First Time Experience
No error, and that's the problem, no console output.

Can be related with 816978, but I'm not sure.
gaia triage : we think that this may be a dup; noming for + just in case.
Assignee: nobody → l10n
Keywords: late-l10n
Priority: -- → P1
Whiteboard: dupme

Comment 4

6 years ago
I don't have time to work on this.
Assignee: l10n → nobody
blocking-basecamp: ? → +

Comment 5

6 years ago
looks like the first step is to see if the patch in https://bugzilla.mozilla.org/show_bug.cgi?id=816978 fixes this first.  kaze, any thoughts?
(Assignee)

Comment 6

6 years ago
Willyaranda: I can take a look at this. Can you provide me STR?
I just updated to latest unagi nightly, and reset the phone so I can launch the phone with a new profile and see the FTU.

Also, if you compile your own sources, it's right after the first flash. Maybe Ben can provide you the links to nightly MoCo builds (I don't have access to them).

I think the best way is to check if in the nightly files to flash, apps are translated (look for homescreen.es.properties, for example)
Assignee: nobody → gandalf
Target Milestone: --- → B2G C3 (12dec-1jan)
Whiteboard: dupme → dupme [target:12/21]

Comment 8

6 years ago
Willyaranda, did we resolve this with bug 817286 ?
Flags: needinfo?(willyaranda)
Yes, working correctly
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(willyaranda)
Resolution: --- → FIXED

Updated

6 years ago
Keywords: late-l10n
You need to log in before you can comment on or make changes to this bug.