If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp.onBackPressed(GeckoApp.java)

RESOLVED FIXED in Firefox 21

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: Scoobidiver (away), Assigned: wesj)

Tracking

({crash, regression, topcrash})

20 Branch
Firefox 23
ARM
Android
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox20- wontfix, firefox21+ verified, firefox22 verified, firefox23 fixed)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Bug 781143 is not fully fixed.
Indeed, there's one crash in 20.0a1/20121210: bp-9d8a9715-faac-4060-be4a-ddac92121210.

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoApp.onBackPressed(GeckoApp.java:2458)
	at android.app.Activity.onKeyUp(Activity.java:2131)
	at android.view.KeyEvent.dispatch(KeyEvent.java:2655)
	at android.app.Activity.dispatchKeyEvent(Activity.java:2361)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchKeyEvent(PhoneWindow.java:2026)
	at android.view.ViewRootImpl.deliverKeyEventPostIme(ViewRootImpl.java:3577)
	at android.view.ViewRootImpl.deliverKeyEvent(ViewRootImpl.java:3533)
	at android.view.ViewRootImpl.deliverInputEvent(ViewRootImpl.java:3115)
	at android.view.ViewRootImpl.doProcessInputEvents(ViewRootImpl.java:4155)
	at android.view.ViewRootImpl.enqueueInputEvent(ViewRootImpl.java:4134)
	at android.view.ViewRootImpl$WindowInputEventReceiver.onInputEvent(ViewRootImpl.java:4226)
	at android.view.InputEventReceiver.dispatchInputEvent(InputEventReceiver.java:171)
	at android.os.MessageQueue.nativePollOnce(Native Method)
	at android.os.MessageQueue.next(MessageQueue.java:125)
	at android.os.Looper.loop(Looper.java:124)
	at android.app.ActivityThread.main(ActivityThread.java:4965)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:791)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:558)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.GeckoApp.onBackPressed%28GeckoApp.java%29

Updated

5 years ago
Assignee: nobody → margaret.leibovic

Comment 1

5 years ago
I don't have the cycles to work on this right now.
Assignee: margaret.leibovic → nobody
(Reporter)

Comment 2

5 years ago
It's #14 top crasher in 20.0a1.
Keywords: regression
Version: Trunk → Firefox 20
(Reporter)

Updated

5 years ago
status-firefox21: --- → affected
(Reporter)

Comment 3

5 years ago
It's #9 top crasher in 20.0a2 and #54 in 21.0a1.
tracking-firefox20: --- → ?
Keywords: topcrash

Comment 4

5 years ago
The crash volume is so low that we're going to leave this on the nom list until after b1 of FF20 is released. Until that time, not worth devoting engineering attention.
(Reporter)

Updated

5 years ago
status-firefox22: --- → affected
Since we released the mobile beta on Monday we're still waiting here for more data collection.
Volume appears stable here, at #15 for Fennec top crashes, not tracking.
tracking-firefox20: ? → -
(Reporter)

Updated

5 years ago
Keywords: topcrash
Hey Aaronmt, do you have a moment to try taking a stab at figuring out where the null pointer check might need to go?
Flags: needinfo?(aaron.train)
Keywords: qawanted
Better to go with Wes who reviewed Margaret's patch the first time-around; just about everything in onBackPressed already looks like it has a null-check.
Flags: needinfo?(wjohnston)
Flags: needinfo?(aaron.train)
Flags: needinfo?
(Assignee)

Comment 9

5 years ago
Created attachment 730754 [details] [diff] [review]
Patch?

This is the only thing that stood out to me. mLayerView is initialized in initializeChrome as well and might be null? Thant matches with the line number from here:

https://crash-stats.mozilla.com/report/index/c410f016-ad66-414a-b107-6a5f82130328
Attachment #730754 - Flags: review?(margaret.leibovic)
Flags: needinfo?(wjohnston)
Flags: needinfo?

Updated

5 years ago
Attachment #730754 - Flags: review?(margaret.leibovic) → review+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/633e6b75af95
Request uplift please. We want this on Fx22 at a minimum.
https://hg.mozilla.org/mozilla-central/rev/633e6b75af95
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
(Reporter)

Comment 13

5 years ago
It's #8 top crasher in 20.0.
tracking-fennec: --- → ?
tracking-firefox21: --- → ?
Keywords: topcrash

Updated

5 years ago
tracking-firefox21: ? → +
(In reply to Wesley Johnston (:wesj) from comment #10)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/633e6b75af95

Wes, can you please request nomination for uplift here ?
(Assignee)

Comment 15

5 years ago
Comment on attachment 730754 [details] [diff] [review]
Patch?

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Forever
User impact if declined: Crashes if you hit back really early in startup
Testing completed (on m-c, etc.): Landed on mc awhile ago. Looks good!
Risk to taking this patch (and alternatives if risky): Very low risk. Just a null check
String or IDL/UUID changes made by this patch: None.
Attachment #730754 - Flags: approval-mozilla-beta?
Attachment #730754 - Flags: approval-mozilla-aurora?
Comment on attachment 730754 [details] [diff] [review]
Patch?

low risk, just a null check and avoids a top-crash. Approving on beta/aurora.
Attachment #730754 - Flags: approval-mozilla-beta?
Attachment #730754 - Flags: approval-mozilla-beta+
Attachment #730754 - Flags: approval-mozilla-aurora?
Attachment #730754 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/e45b9cf150e1
https://hg.mozilla.org/releases/mozilla-beta/rev/7485b8561100
status-firefox20: affected → wontfix
status-firefox21: affected → fixed
status-firefox22: affected → fixed
status-firefox23: --- → fixed
(Reporter)

Comment 18

5 years ago
There are no crashes in 21.0b2 and above and after 22.0a2/20130408.
status-firefox21: fixed → verified
status-firefox22: fixed → verified

Updated

4 years ago
Keywords: qawanted
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.