If a device contact without name and last name is linked to a FB friend, those fields appear as empty in Contacts App

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
--
major
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: sonmarce, Assigned: Jose Manuel Cantera)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
*Procedure
1-Create a contact only with phone number filled
2-Link the concat to a FB contact with name and surname filled.

*Expected Result
The contact is linked and shows the name and surname of FB contact

*Actual Result
The fields name and surname are showing empty in contact details
(Assignee)

Updated

6 years ago
Assignee: nobody → jmcf
(Assignee)

Updated

6 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

6 years ago
I'm gonna implement this bug as follows:

If the deviceContact has givenName and familyName, it will be take precedence over the FB Name.

If givenName or familyName are empty, then the FB correspondence will be taken i.e. if the givenName is given but not the familyName the final name will be device(givenName), facebook(familyName) and viceversa. if none of them are device-defined then the FB Name will appear. 

Please take into account that FB names will be subject to local changes made by the user. 

Please confirm that you agree with this approach

thanks!
(Assignee)

Comment 2

6 years ago
Created attachment 691547 [details]
Pointer to GH PR 6985
Attachment #691547 - Flags: review?(crdlc)
(Assignee)

Updated

6 years ago
Summary: If you link a contact without name and last name filled to a contact FB, the fields are showing empty in contact details → If a device contact without name and last name is linked to a FB friend, those fields appear as empty in Contacts App
Attachment #691547 - Flags: review?(crdlc) → review+
(Assignee)

Comment 3

6 years ago
Comment on attachment 691547 [details]
Pointer to GH PR 6985

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: UX will be bad and a nice FB feature will lost 

Testing completed: 
Risk to taking this patch (and alternatives if risky):

Master can judge himself but the risk is low
Attachment #691547 - Flags: approval-gaia-master?(francisco.jordano)
Comment on attachment 691547 [details]
Pointer to GH PR 6985

Changing affecting to fb enabled.

JS check looking good, also got the r+, plus needed late mini feature.
Attachment #691547 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
2012/28/01 build. Gecko-cfad7c9 Gaia-6c53dfd
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.