[Trusted UI] Don't resize the trusted UI prompt when the keyboard appears

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: alberto.pastor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 690463 [details]
Identity White Blob

Build:

Device - Unagi
Date - 12/10/2012 Mozilla Beta
Prefs - Identity is prefed on

Steps:

1. Go to marketplace
2. Select to login
3. Select the enter your email address text field

Expected:

The keyboard should come up with the persona dialog being responsive to a smaller dialog.

Actual:

See screenshot. It looks like the dialog isn't handling responsive design to when a dialog becomes smaller too well.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
(Reporter)

Updated

5 years ago
Blocks: 794552
(Reporter)

Updated

5 years ago
Blocks: 811528
(cc :jcarpenter)

Jason, I have been seeing this, too.

As a quick test, I tried turning off native identity.  That keeps the same UI, but causes the dom methods to be executed in the js shim.  So it circumvents the trusty UI and appears as a new tab in b2g.  When I do this, I see the dialog laid out normally, with no white blob.  (It works similarly on android.)  In other words, the white blob appears only when the dialog is rendered inside the trusty ui.

This makes me suspect that the problem here may not be an identity bug, but something in either the Trusty UI layout or other system styles.
(Reporter)

Updated

5 years ago
Component: Identity → Gaia::System
Product: Core → Boot2Gecko
Version: Trunk → unspecified
(Reporter)

Updated

5 years ago
Blocks: 801561
No longer blocks: 794552
Summary: Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears → [Trusted UI] Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears
Triage: does it break usage? or it simple looks weird from the UI?
Flags: needinfo?(jsmith)
(Reporter)

Comment 3

5 years ago
(In reply to Joe Cheng from comment #2)
> Triage: does it break usage? or it simple looks weird from the UI?

Combination of this issue + bug 820059 basically right now makes it incredibly difficult to complete a login.

When we decide to pref this on (once the "smoketest" of it passes), both of these bugs would be classified as smoketest blockers (this becomes a smoketest when this prefs on for context).
Flags: needinfo?(jsmith)
Triage: Looks like a major usability bug
blocking-basecamp: ? → +
Priority: -- → P2
(Reporter)

Comment 5

5 years ago
it's debatable if this is a trusted UI bug or a keyboard bug
(Assignee)

Updated

5 years ago
Assignee: nobody → alberto.pastor
I am not seeing this with the mozPay flow for the mock payment provider, so it might be related to the content loaded within the trusted UI.
(Assignee)

Comment 7

5 years ago
Created attachment 690993 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6957

Pointer to Github pull-request
(Reporter)

Updated

5 years ago
Blocks: 820059
(Assignee)

Updated

5 years ago
Attachment #690993 - Flags: review?(ferjmoreno)
(Reporter)

Comment 8

5 years ago
So it turns out after digging into this with Jed that the attached patch will not fix the original issue. Apparently this bug reproduces on slow network connections when connecting to persona - whether that be the shim or the native implementation.

It's still worth landing, but what's landed doesn't inherently block basecamp. So this will need approval.
blocking-basecamp: + → ---
Summary: [Trusted UI] Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears → [Trusted UI] Don't resize the trusted UI prompt when the keyboard appears
(Reporter)

Updated

5 years ago
No longer blocks: 811528, 820059
Priority: P2 → --
Comment on attachment 690993 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6957

I believe what this patch does will cause new regression because keyboard resize is canceled but no anywhere to deal with it again.
Attachment #690993 - Flags: feedback-
(Reporter)

Comment 10

5 years ago
I'm actually going to wontfix this - the point made in comment 9 and a past bug indicates we shouldn't do this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Looks like Bug 818575 - Content becomes white after tapping into a text area from a shortcut made on the homepage.

I don't think this is a keyboard issue since that white area was not be painted by keyboard app. itself.

Hi Jason,

Do you mean by closing this issue so that we could track "white area issue" with Bug 818575?

Thanks.
(Reporter)

Comment 12

5 years ago
(In reply to Rudy Lu [:rudyl] from comment #11)
> Looks like Bug 818575 - Content becomes white after tapping into a text area
> from a shortcut made on the homepage.
> 
> I don't think this is a keyboard issue since that white area was not be
> painted by keyboard app. itself.
> 
> Hi Jason,
> 
> Do you mean by closing this issue so that we could track "white area issue"
> with Bug 818575?
> 
> Thanks.

I actually morphed this bug into doing the don't resize logic, but after hearing Alive's comments, I marked it as a won't fix since a blocking regression will occur if we implement this.
Comment on attachment 690993 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6957

No need for review then.
Attachment #690993 - Flags: review?(ferjmoreno)
You need to log in before you can comment on or make changes to this bug.