Selection listeners are not applied on document reload (sometimes throws error)

RESOLVED FIXED

Status

Add-on SDK
General
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: zer0, Assigned: zer0)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
If the same document is reloaded, the selection listeners are not applied again, and therefore they're gone.
Sometime if the previous selection is already detached, it will throw an exception as well.

This bug is probably the cause of the bug 816177 and bug 819551.
(Assignee)

Updated

5 years ago
Blocks: 816177, 819551
(Assignee)

Comment 1

5 years ago
Created attachment 690534 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/681

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #690534 - Flags: review?(rFobic)

Comment 2

5 years ago
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/4ded605503753e90ba508c3c11b8b171e2c8d29a
Merge pull request #681 from ZER0/selection-reload/820095

Bug 820095 - Selection listeners are not applied on document reload r=@gozala
Comment on attachment 690534 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/681

I have landed this as it fixes bunch of error messages in tests, but please make sure to write a test for this fix before closing this bug.
Attachment #690534 - Flags: review?(rFobic) → review+

Updated

5 years ago
Priority: -- → P2
(Assignee)

Comment 4

5 years ago
Created attachment 694336 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/696

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #694336 - Flags: review?(rFobic)
Attachment #694336 - Flags: review?(rFobic) → review+

Comment 5

5 years ago
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/4dff7c0db68a4271dd87369bb5c88999d68a29e1
Merge pull request #696 from ZER0/selection-reload/820095

fix Bug 820095 - Selection listeners are not applied on document reload r=@gozala

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Assignee: nobody → zer0
This looks like it broke several test platforms: https://tbpl.mozilla.org/?tree=Jetpack&rev=dc659b901a6d

Updated

5 years ago
Depends on: 824115
You need to log in before you can comment on or make changes to this bug.