Include the checked out installer.ini file in the mac installer

VERIFIED INVALID

Status

P2
critical
VERIFIED INVALID
18 years ago
14 years ago

People

(Reporter: samir_bugzilla, Assigned: samir_bugzilla)

Tracking

Trunk
mozilla0.9.1
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
It appears that we are including an outdated version of the installer.ini file
with the installer which causes certain strings to not show up: the result is
the pause/resume buttons showup with garbage text.
(Assignee)

Comment 1

18 years ago
We can't ship beta1 like this; hence, nominating.  This is very higly visible in
the first impression of users installing mozilla/netscape.  Hence, marking critical.
Severity: normal → critical
Keywords: nsbeta1

Comment 2

18 years ago
setting 0.9.1 so it shows up on the radar.  cc mcarlson since this sounds like
it might have l10n impact.

Where do we get the correct installer.ini and where is it supposed to go?
Priority: -- → P2
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 3

18 years ago
No, this will not have an l10n impact.  These are string changes that were
actually part of Ying-lin's landing last week.  Ying-lin is the i18n engineer
who implemented the installer.ini feature to read strings from a text file
rather than from resourced string lists for the mac installer.

This is purely a build issue.  I know for a fact that the strings were checked
in before Ying-lin made up the l10n kit that is sent out to the localizers.

JJ knows where the updated installer.ini file is to be delivered: under
mozilla/xpinstall/wizard/mac/macbuild/Installer Modules/installer.ini and needs
to be at <installer folder>:Installer Modules:installer.ini.  Note, he already
delivers the installer.ini, just not the checked out version.  
(Assignee)

Comment 4

18 years ago
*** Bug 82026 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
I looked at 05-21-15-trunk build and the installer.ini found in the mozilla 
installer matches exactly the one in the mozilla tree.
However, the 2 recently added properties:
> instBtnPause=Pause
> instBtnResume=Resume
were NOT added to the Netscape flavor of the file (same location in the ns tree)
which could explain the garbage strings in the Netscape installer. It was not 
clear to me if this was a mozilla or a netscape bug to begin with.

I also reviewed the automation to make sure the proper installer.ini was getting 
bundled with each installer. No bug found.
Note that I change the file type/creator to match those of config.ini : 'INI '/
'MzIn' or 'INI '/'NsIn' (this doesn't seem to be a problem since the file is 
properly read)

Back to you, Samir.
Assignee: jj → sgehani
(Assignee)

Comment 6

18 years ago
Damn!  Why do we have separate installer.ini files for both trees?  This is bad
architecture.  We are going to get bitten by this over and over.  Anyways, can't
do much for mozilla0.9.1.  In the future we should only store common strings in
the installer.ini.  

Opening a new bugscape bug.  This bug is invalid at this point.  
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 7

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.