bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Zooming out with lots of position: absolute and moz-transform causes crash and reboot of Otoro device

RESOLVED WONTFIX

Status

Firefox OS
General
--
critical
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({crash, testcase})

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)
crash, testcase

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(URL)

(Reporter)

Description

6 years ago
I'm seeing a crash on the url testcase on my Otoro device. It happens when I try to zoom out on that page as far as possible, using pinch-zoom.

It can take a little while before the crash happens.
Perhaps, you need to pinch-zoom a little in and out for the crash to happen.
I think this may be a dupe, but could do with a platform person to investigate the crash further?
Component: Gaia::Browser → General
QA Contact: nhirata.bugzilla
Jeff, can you take a look, as you're in the zoom code right now?  Also the "reboot the device" could be "restarting the main B2G app".
Assignee: nobody → jmuizelaar
blocking-basecamp: ? → +
Whiteboard: [b2g-gfx]
Martijn, is there a way to get a stack here?  Also, does it happen on Android, or just Firefox OS?
Flags: needinfo?(martijn.martijn)
I expect this is just OOM. But can't reproduce it reliably enough to confirm.

Updated

6 years ago
Target Milestone: --- → B2G C3 (12dec-1jan)
Martinj, do you still see the crash?
Flags: needinfo?(martijn.martijn)
(In reply to Milan Sreckovic from comment #5)
> Martinj, do you still see the crash?

And if you do can check to see if it's just happening because of OOM?
Yeah. I can't reproduce this at all.
blocking-basecamp: + → ?

Comment 8

6 years ago
If we can get a crash ID from someone hitting it, this would be good, as we could get a stack and further info.
We actually agreed to - this if we don't get a confirmation of being reproducible.  If somebody runs into again, please renom.
blocking-basecamp: ? → -
(Reporter)

Comment 10

6 years ago
Sorry, because of bug 821296, I couldn't test this (that bug seems to be wfm, currently).

I did retest, after zooming out a bunch of times, reloading, and then clicking on the doe button, I did seem to get a crash. After that, the whole Otoro phone became unusable. I got a black screen. Removing the battery didn't help. I had to reflash.
This was with yesterday's mozilla-b2g18-otoro build.

I couldn't test with mozilla-central otoro build, since there I'm getting bug 821296 again.
Flags: needinfo?(martijn.martijn)
Assignee: jmuizelaar → nobody
blocking-basecamp: - → ?
Whiteboard: [b2g-gfx]

Comment 11

6 years ago
Dropping for now - we need to figure out how to get better STR.  With it so hard to trigger atm, we wouldn't block ship.
blocking-basecamp: ? → -
(Reporter)

Comment 12

6 years ago
I just filed bug 831313, which might be the same as this bug perhaps.
Can you please provide logcat for this crash?
(Reporter)

Comment 14

2 years ago
Marking WONFTIX, sorry for the bug spam. If somebody still wants to work on this, please open a new bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.