Importing Eudora setting will fail to create an identity if the user didn't specify a return address in Eudora

VERIFIED FIXED in mozilla0.9.1


MailNews: Message Display
17 years ago
14 years ago


(Reporter: Ninoschka Baca, Assigned: (not reading, please use instead))



Firefox Tracking Flags

(Not tracked)


(Whiteboard: [nsbeta1+])


(4 attachments)



17 years ago
Build 2001-05-17-04: Mac 9.04

Overview: Import Eudora Settings and in the Account Settings dialog it displays 
one panel which looks like "Local Folders". Instead it should show atleast the 
Identity, Server and 'Copies and Folders' panels.

Steps to reproduce:
1. Select File|Import
2. Select the Settings radio button
3. Select Eudora
4. Select the Eudora Settings file on your hard drive
5. When the import is finished it should display:

Eudora Settings
- Inbox
- Drafts
- Templates
- Sent 
- Trash

6. Select the Inbox, select the "Get Msg" button and messages are retrieved
7. Select Edit|Mail/News Account Settings
8. Select the Eudora Settings account

Actual Results: Notice that there is only one text field named Account Name 
which is similar to the "Local Folders" structure. After an exit/restart it 
still appears the same way.

Expected Results: There should atleast be the Identity panel, Server panel, and 
Copies and Folders panel.

Comment 1

17 years ago
Marking nsbeta1 because there should be a way to manipulate settings and to see 
the current status of the settings.
Assignee: sspitzer → chuang
Keywords: nsbeta1
QA Contact: esther → nbaca
all, this is win32 and mac.  (no eudora on linux)

that should only happen if there is no identity associated with the account.

I'll go check if that logic regressed and make sure there is an identity. 
OS: Mac System 9.x → All
hmm, there is no identity.  but that makes sense now that I think about it.

I imported mail, not settings.  if I just imported mail, how would I have an
identity?  how would I have server settings?  all I'd have are imported mail

this sounds like the correct behaviour.

Comment 4

17 years ago
This bug is for importing Eudora Settings which should display an identity.

Also, this problem only occurs on the Mac. On windows it displays an identity.
ok, thanks for clarifying.  the subject says "settings", I must have been asleep
at the wheel.

ninoschka, looking at your prefs on the mac, is there an identity for the eudora
settings?  if there is one, is it "hooked up" with the eudora server?  (can you
attach your prefs.js to this bug?)

I can help debug this tomorrow.

Comment 6

17 years ago
Created attachment 35642 [details]
Import Settings/Eudora prefs.js
Assignee: chuang → sspitzer
Target Milestone: --- → mozilla0.9.2
this worked for me.  

I set up a eudora account [eudora 5.1] on my mac.

I created a new profile, launch mail.  set up a news profile when mail launches
(the wizard comes up when you don't have any profiles).

import the "Eudora Settings" file.  worked fine.  I don't see this problem.
I'll attach my eudora settings file.  can you attach yours?

did you trim anything off your prefs.js file?  I don't even see a local folders.

you don't have an identity which would explain why you don't see the panels in
the account settings dialog.
actually, you might need to email me your eudora settings file.  It might be a
special mac file.  I wasn't able to view mine with bbedit.  maybe all the info
lives in the resource fork for the file?
ok, I'm able to reproduce this.

in eudora, when you set up your account you don't have to put your Return
address if it is Username@MailServer (Username and MailServer for checking mail)

when I first tried eudora, my return address (email address) was not
Username@Mailserver, so it worked.

working on a fix.
you can make the same thing happen on eudora on win32.

I've got a fix for both the mac and the win case.  the fix is to do what eudora 
does internally:  if no return address, use username@hostname

patch coming soon.
Hardware: Macintosh → All
Created attachment 35936 [details]
fix for mac problem
Created attachment 35937 [details] [diff] [review]
windows fix for eudora setting import
Created attachment 35938 [details] [diff] [review]
v2 of the win fix, forgot to change = to +=
those two patches fix this problem for me with Eudora.
the final patch to review are these two patches:

I'll attach a single patch tomorrow.

cavin, can you review?
Summary: Import Eudora Settings and it appears as "Local Folders" → Importing Eudora setting will fail to create an identity if the user didn't specify a return address in Eudora


17 years ago
Priority: -- → P2
Whiteboard: [nsbeta1+]

Comment 17

17 years ago
trying to get into 0.9.1

unlike other bugs where future release can fix the problem, once you import, 
you're hosed.
Target Milestone: mozilla0.9.2 → mozilla0.9.1

Comment 19

17 years ago

Comment 20

17 years ago
approved for checkin to 0.9.1
--Asa (on behalf of drivers)
some background:

In Eudora, return address is your email address.

so if I were to set up eduora for my netscape mail, it'd be

sspitzer (username) (hostname) (return address)

but if return address is username@hostname the
Eudora setup wizard tells you don't need to enter a return address.

this exposes the bug.
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 23

17 years ago
Build 2001-05-31-04: WinMe
Build 2001-05-31-08: Mac 9.04

Using the 5/21 build, on Win and Mac, I was able to reproduce the problem if
Eudora had no entry for the "return address".

Using the 5/31 build, on Win and Mac, it appears fixed because now I see the
correct panels in the Account Settings dialog (Identity, Server, Copies and
Note: Since there is no "return address" in Eudora I noticed that various areas
reference "nsmail-2" in the email address instead of, is
this ok? I would expect to see

- in Account Settings, the Identity panel's Email Address states "qatest@nsmail-2"
- when creating a new message, the From drop down displays qatest20
- it was successful sending/receiving a message, and the from: field displays 
qatest20 <qatest20@nsmail-2>
ninoschka,  nice work.

your comment about ending up with "qatest20@nsmail-1" makes sense, although
that's not a fully qualified domain name (FQDN), so it's not a legal email
address.  you could have entered to get a FQDN.

with out a return address, our code has no choice but to create the email from
username@hostname, since that's all we have.

eudora should be doing the same thing, creating your email address from
username@hostname.   that's what my versions of Eudora do.

now that you have explicitly removed the return address from your eudora
accounts, what happens when you send mail from them?  when you receive it, does
it look like it came from qatest20@nsmail-1, or
 if the later, there might be a good reason.  I think our SMTP server does some
header munging.

backing up a step, what were your eudora settings when you originally found this
I'm not sure how much sense my last comment made, I'm a little tired.

ninoschka, we can talk about this over AIM tomorrow and I'll summarize our
discussion in this bug.

Comment 26

17 years ago
Verified Fixed. 

Eudora behaves the same way. 

- In Eudora if the Return Address is removed then the From: field states 
qatest20@nsmail-2. Send/Receive messages is successful. When this profile is 
imported then the Email Address in Account Settings displays 
"qatest20@nsmail-2", again send/receive of messages is successful.
This should be ok because the user can always update the email address to the 

- If the Return Address states states the FQDN (
then it also sends/receives messages successfully. After importing then Account 
Settings' Email Address entry states, as expected.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.