Firefox suddenly stops rendering pages correctly after rendering correctly for a while.

RESOLVED WONTFIX

Status

()

Core
Networking: Cache
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: a_GNUbie, Unassigned)

Tracking

17 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 690721 [details]
Example screenshot of YouTube main page once bug is triggered.

User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Just normal browsing of common web pages such as YouTube, Wikipedia, etc.  Everything is fine "for a while".


Actual results:

Web pages suddenly stop rendering properly.  Items are there but they are not placed or formatted correctly, the background color goes away, and nothing much works.  If I were forced to guess what the problem is based on the appearance of what shows up on my screen I would have to say that Firefox had suddenly forgotten what CSS is.  Firefox essentially becomes useless until I restart it, tho pages rendered before the bug was triggered continue to look OK.


Expected results:

Firefox should have continued to render pages properly as it was when I started the session.  This bug may or may not be related to Bug 392601 (which is several years old).  I do not know if this bug affects other platforms since I only have Linux machines.  This has been going on now for several released versions of Firefox.  I was hoping that Firefox upgrades or my upgrade from Slackware Linux 13.37 to 14.0 would fix the problem, but they have not fixed the problem.  This bug is not specific to one particular website but affects many websites once triggered.
(Reporter)

Comment 1

5 years ago
Created attachment 690724 [details]
Example screenshot of Wikipedia main page once bug is triggered.

Another example screenshot of the bug in action, this time affecting the Wikipedia main page (English).  The bug affects other sites too.
What happens if you press ctrl+f5 to force a reload the page ?

Comment 3

5 years ago
In addition, does clearing the browser cache fix your issues?
http://support.mozilla.org/en-US/kb/how-clear-firefox-cache
Flags: needinfo?(a_GNUbie)

Comment 4

5 years ago
>> What happens if you press ctrl+f5 to force a reload the page ?

Didn't know about ctrl+f5.  Is that different that the reload button?  Anyway will try ctrl+f5 when next Firefox goes out on me, but I *have* tried the reload button and that did not help.

>> In addition, does clearing the browser cache fix your issues?

Haven't tried that.  Will try it the next time the bug occurs.

Thanks,
Jeff B.

Comment 5

5 years ago
Oops.  Shoulda checked the box on my last reply.
Flags: needinfo?(a_GNUbie)
>Is that different that the reload button?
Yes, it's different. A normal reload can use the cached entry while a forced reload (ctrl+f5 or shift+reload-button) will discard the cache entry for this page.

I didn't suggest to clear the cache because that will wipe all information about the probably broken disk cache.

Comment 7

5 years ago
Wikipedia has had technical issues today, so sometimes not everything did load.  Could that be a problem with your connection?

Comment 8

5 years ago
>> Wikipedia has had technical issues today, so sometimes not everything did
>> load.  Could that be a problem with your connection?

No.  It happens with a lot of websites that I've never had problems with before.  It just now happened again with my bank's website.  (Unfortunately I was in the middle of a login which failed so the page went away before I could try the other suggestions above.  Sorry about that.)

Comment 9

5 years ago
Created attachment 692813 [details]
Attempt to follow link of page re-rendered by ctrl+F5 results in incomplete rendering of destination page.

Comment 10

5 years ago
OK, I tried ctrl+f5 and the page was re-rendered properly, but then I
tried to link to another page and got an incomplete rendering as you
see in file I just downloaded by the name of

    Firefox_failure_to_render_YouTube_completely.jpg

I have see that effect before, too.

More: I've done the reload vs. ctrl+F5 test several times now.  Reload
either does not work at all or it accomplishes a partial reload as in
the example above.  On the other hand, ctrl+F5 seems to always render
the page correctly but I have had mixed results with trying to follow a
link off the re-rendered page.

This is very muddled and I don't think it's very helpful.  Sorry it's
taken so long too; I can't make these failure happen on demand.

I will try clearing the cache and reloading next time I see the failure.

Thanks for your time.

Jeff B.

Comment 11

5 years ago
Remove the cache folder manually, type about:cache in location bar and go to the folder named "Disk cache device".

If that fails, try with a new profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Comment 12

5 years ago
Pardon my confusion.  While I am willing to remove the cache as suggested, what do I do next.  Do I put it back after it's been removed?  Do I leave it gone?  Will Firefox even run without a cache?  If Firefox will work without a cache do you want me to remove it before the error re-occurs or after?  Etc?

Thanks,
Jeff B.

Comment 13

5 years ago
Just remove the files inside the cache folder, FF will recreate them automatically.
Restart FF and test again.

And try with a new profile if the issue is still here.

Comment 14

5 years ago
Please let us know if removing you cache resolved your problem.

If it didn't, please try using a new profile and let us know if the issue reappears:
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles. 

You can also create a new profile by going to about:support and clicking the Reset Firefox button. It will create a new profile and import your old profile data on it, except for add-ons, cache etc - information about what is imported is displayed when you click the Reset button (you can just click Cancel if you are not satisfied with what it would import).
Flags: needinfo?(a_GNUbie)

Updated

5 years ago
Component: Untriaged → Layout
Product: Firefox → Core
In case of a cache problem it could be bug 808532

Comment 16

5 years ago
Sorry it's taken so long to get back to you all.  The failure has not
occurred again until just a few minutes ago.

Just as a test of repeatability I hit the reload button and the page
reloaded incorrectly (YouTube main page).  Then I did an ordinary cache
clear through Tools --> Clear Recent History.  I specifically cleared
nothing else; just the cache.  Then I hit the reload button again and
the page loaded properly.

Next I tried bringing up the same page in a new tab.  No problem.
Loaded a couple of other main pages without problem.  I tried going
to other pages from the pages which I just loaded an did so without
problem.

I know the above is just a single instance but it's all I can tell you
for now.

Thanks,
Jeff B.

PS: Happy New Year

Comment 17

5 years ago
Very thin clue: I had YouTube go out on me so I tried loading some other
websites in other tabs without clearing the cache.  YouTube again: fail.
NetFlix: success.  Wimp.com: success.  Wikipedia: fail.
CNN.com: success.  YouTube again: fail.  Wikipedia again: fail.  My
library: success.  Amazon.com: success.  WashingtonPost.com: success.
IMDB.com: success.  Boston.com: success.  YouTube: still failing.
bugzilla.mozilla.org: success.  Wikipedia: Still failing.

Then I did a normal cache clear, JUST the cache, via Tools -->
Clear Recent History, and then revisited and reloaded all the tabs:
SUCCESS on all.

The very thin clue here is that of all the pages I happened to load this
time only two failed, YouTube then Wikipedia.  I have seen that pattern
before now that I think on it.  I frequently watch YouTube videos and
when I see something interesting I go look it up on Wikipedia.  So, all
this leads me wondering if there is some item common to both YouTube and
Wikipedia which triggers or is triggered by the failure?  And now that I
reflect on it further I don't recall seeing the failure when I am not
using YouTube.  I can be using a plethora of other sites but when none of
them are YouTube I don't see the problem.

I know the above is hardly rigorous but that's all I can tell you at the
moment, but that's kind of the nature of chasing intermittent faults
(which I used to do for a living).  So far clearing the cache seems to
be a successful work-around for the problem.

I'm still happy to try other things to get you more information, so I am
open to further suggestions.


Jeff B.
Flags: needinfo?(a_GNUbie)
Component: Layout → Networking: Cache
all new cache code since this was reported
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.