Closed Bug 820305 Opened 8 years ago Closed 8 years ago

E.me apps -> Firefox doesn't know how to open this address

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect, P1)

x86_64
Linux
defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
B2G C3 (12dec-1jan)
blocking-basecamp +

People

(Reporter: etienne, Assigned: ochameau)

References

Details

(Keywords: regression, smoketest, unagi)

Attachments

(2 files)

Attached image Screenshot
Tried 5-6 apps for the "imdb" search during the smoke tests.
Everyone of them had the attached loading error:

> Firefox doesn't know how to open this address, because the protocol (window) isn't 
> associated with any program.

See attachment.
Of course the Internet connexion was working properly at the time of the test (tested with the browser app).
I see this as well while smoketesting today's daily build - I selected some sites under shopping such as "Macys" and "overstock" and I get the same error:

Using Gecko f1c0c74ea9f5 and Gaia bf21e0c83930. Nominating for blocking
blocking-basecamp: --- → ?
Keywords: smoketest, unagi
I'm seeing these errors in the log:
E/GeckoConsole(21319): [JavaScript Error: "TypeError: currentFolder is null" {file: "app://homescreen.gaiamobile.org/everything.me/js/Brain.js" line: 884}]

E/GeckoConsole(21279): [JavaScript Error: "NS_ERROR_UNKNOWN_PROTOCOL: Component returned failure code: 0x804b0012 (NS_ERROR_UNKNOWN_PROTOCOL) [nsIDOMLocation.replace]" {file: "app://system.gaiamobile.org/js/error.js" line: 7}]

The second one appears after hitting the "try again" button in the error page, so the first one is probably what needs investigating.
Triage: Etienne, do you think this is a bug in Gaia, Gecko or the web sites being accessed?
Flags: needinfo?(etienne)
Given Margaret's comment I'd say Gaia :)
Flags: needinfo?(etienne)
Smoketest blocker.
blocking-basecamp: ? → +
Priority: -- → P1
Need to find an assignee -- Vivien, can you suggest the right person here?
Assignee: nobody → 21
Severity: normal → critical
Target Milestone: --- → B2G C3 (12dec-1jan)
(In reply to Dylan Oliver [:doliver] from comment #7)
> Need to find an assignee -- Vivien, can you suggest the right person here?

I don't know who's working on e.me, but someone working on that would be a good assignee. 

It looks like a pretty big refactoring landing recently, so I wonder if this could be a regression from that:
https://github.com/mozilla-b2g/gaia/commit/0464482951cab89e046514c7c936807139606d71#apps/homescreen/everything.me/js/Brain.js

I can't find rabena on bugzilla, so I'm cc'ing crdlc because he's the reviewer there.
Margaret, thanks for the pointer -- assigning to Evyatar.

Ran/crdlc, do we need to back out bug 813026? I'm unable to launch any apps from e.me.
Assignee: 21 → evyatar
Keywords: regression
Duplicate of this bug: 821125
Hey guys. I'm not able reproduce the bug.
All scenarios open the clicked apps successfully and without any JS error.
I'm working on 12/12 Otoro Gecko build and latest Gaia 4d47a2a9fb6

Please lmk if the bug consists after updating Gaia.
Is there any chance this could be because of bug 807438?

It seems it has landed in Gaia and the required Gecko part only in m-c, not in Beta. Not sure but just wanted you to have a look it.

If I am right, can someone request beta checkin or backout gaia change?
Flags: needinfo?(poirot.alex)
(In reply to Daniel Coloma:dcoloma from comment #12)
> Is there any chance this could be because of bug 807438?

Can be a regression of this bug just because it modified some code related to e.me. But it's not due to gecko part not being in beta, as I modified the gaia patch in order to *not* depend on gecko patch.
Flags: needinfo?(poirot.alex)
(In reply to Alexandre Poirot (:ochameau) from comment #13)
> (In reply to Daniel Coloma:dcoloma from comment #12)
> > Is there any chance this could be because of bug 807438?
> 
> Can be a regression of this bug just because it modified some code related
> to e.me. But it's not due to gecko part not being in beta, as I modified the
> gaia patch in order to *not* depend on gecko patch.

See also https://bugzilla.mozilla.org/show_bug.cgi?id=821546#c3, if you believe it can be a regression, can you have a look at this? it's bb+ P1 and is making e.me not work at all.
Sorry If I wrong but I can view [1] origin = 'window:' + name + ',source:' + callerOrigin; . Could it be related?

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/window_manager.js#L1512
(In reply to crdlc from comment #15)
> Sorry If I wrong but I can view [1] origin = 'window:' + name + ',source:' +
> callerOrigin; . Could it be related?
> 
> [1]
> https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/
> window_manager.js#L1512

That sounds related :/
(In reply to Vivien Nicolas (:vingtetun) from comment #16)
> (In reply to crdlc from comment #15)
> > Sorry If I wrong but I can view [1] origin = 'window:' + name + ',source:' +
> > callerOrigin; . Could it be related?
> > 
> > [1]
> > https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/
> > window_manager.js#L1512
> 
> That sounds related :/

Will it be fixed if the gecko part for bug 807438 lands on beta as you requested? Just wondering if we need to do something else as comment 13 said there was no Gecko dependency.
(In reply to crdlc from comment #15)
> Sorry If I wrong but I can view [1] origin = 'window:' + name + ',source:' +
> callerOrigin; . Could it be related?
> 
> [1]
> https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/
> window_manager.js#L1512

That's most likely related to this code.
I'm still not able to reproduce it, but I'll try again with different builds.
Assignee: evyatar → poirot.alex
(In reply to Alexandre Poirot (:ochameau) from comment #18)
> (In reply to crdlc from comment #15)
> > Sorry If I wrong but I can view [1] origin = 'window:' + name + ',source:' +
> > callerOrigin; . Could it be related?
> > 
> > [1]
> > https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/
> > window_manager.js#L1512
> 
> That's most likely related to this code.
> I'm still not able to reproduce it, but I'll try again with different builds.

It is consistently failing with Gecko beta, it has been reported in different smoke tests. 

Last time I've seen reported is in 14th Dec Smoke Tests:

gecko: 1fd108c5aee3ea2553938d34eb75e7f52c110f6c
gaia: 16006ea0104f6c1518f27bb00e3713ca31b83c5d
Thanks daniel, using beta is the key point to see this failure.

So there is two distinct issues:
- when we load e.me app, the first document load fails for some unknown reason. Given that this regression only happens on beta, I'll think that it is a gecko regression.
- in case of document load failure, bug 807438 broke the "try again" action on loading failure. The error dialog takes the origin instead of using the current frame URL:
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/modal_dialog.js#L242

If I backout bug 807438, the e.me apps still fail to load on first try. So that you always have to hit "try again" button. I'll try to submit a patch to fix this later today.
(In reply to Alexandre Poirot (:ochameau) from comment #20)
> - when we load e.me app, the first document load fails for some unknown
> reason. Given that this regression only happens on beta, I'll think that it
> is a gecko regression.

This issue has already been reported in bug 821527 and is going to be fixed by uplifting bug 816452.
(In reply to Alexandre Poirot (:ochameau) from comment #20)
> - in case of document load failure, bug 807438 broke the "try again" action
> on loading failure. The error dialog takes the origin instead of using the
> current frame URL:
> https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/modal_dialog.
> js#L242

Here is a patch to fix that regression. Bug 807438 introduced new kind of apps origins that looks like this:'window:$(window name),source:$(source app origin)'
And error dialog takes this origin when reloading the document although it isn't a valid URL.
In this patch I save the original frame url in window manager in order to reuse it on load error.
Attachment #692948 - Flags: review?(alive)
Duplicate of this bug: 821546
Alive can you review today please?
(In reply to Dietrich Ayala (:dietrich) from comment #24)
> Alive can you review today please?
Sorry I am not at office from yesterday to today. Please find another reviewer. Will be available to review tomorrow.
Comment on attachment 692948 [details]
Pull request 7041 - fix bug 807438 regression

Taipei team building, please find another reviewer who are not belong toTaipei team to review if this is urgent today. Sorry for late response. I will be available tomorrow:)
Attachment #692948 - Flags: review?(alive)
Duplicate of this bug: 822286
Verified fixed the ability to visit imdb from within Everything.me using Unagi with the following:

Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/406b86b4b515
Gaia: c5a8b6476f0dbc456061227a7801e56634683eb0
Build ID: 20130319070203
Verified fixed the ability to visit imdb from within Everything.me using Unagi with the following:

Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/406b86b4b515
Gaia: c5a8b6476f0dbc456061227a7801e56634683eb0
Build ID: 20130319070203
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.