Closed Bug 820426 Opened 10 years ago Closed 10 years ago

An unexpected "self-hosted" script appears in the debugger's script list

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 21

People

(Reporter: past, Assigned: vporof)

References

Details

Attachments

(3 files)

Some time during the last few weeks a weird item started appearing in the debugger's script list, named 'self-hosted'. The 'script' contents look like the contents of the inode of the root directory (see the attached screenshots).

A quick search shows this code as the most likely candidate for setting this file name:

http://mxr.mozilla.org/mozilla-central/source/js/src/jscntxt.cpp#383
Bug 787927 seems related. Till, is this a dupe of your bug?
Depends on: 787927
Attachment #690915 - Attachment description: Linux svreenshot from about:home → Linux screenshot from about:home
Yes, yes - it is! Thanks for letting me know about it, I couldn't reproduce the issue anymore and was on the verge of closing the bug.

Refreshing the patch now.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Priority: -- → P3
We'll just ignore "self-hosted" for now.
Attached patch v1Splinter Review
Attachment #700941 - Flags: review?(past)
Comment on attachment 700941 [details] [diff] [review]
v1

Review of attachment 700941 [details] [diff] [review]:
-----------------------------------------------------------------

Don't forget to make the comments more generic to cover this case as well.
Attachment #700941 - Flags: review?(past) → review+
Till, we're going to work around this until your fix lands, so if you want to keep encountering this for tests you'll have to back out locally.
Addressed comment and landed:
https://hg.mozilla.org/integration/fx-team/rev/0022484dedd7
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0022484dedd7
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.