'Set as Desktop Background...' not working

RESOLVED DUPLICATE of bug 1119088

Status

()

RESOLVED DUPLICATE of bug 1119088
6 years ago
9 months ago

People

(Reporter: BenWa, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR:
1) Open http://i.imgur.com/GO2uZ.jpg
2) Right click and select 'Set as Desktop Background...'

I'm unable to set it as a background image using this feature.

Comment 1

6 years ago
This worksforme with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20121211 Firefox/20.0

1) Right-click on the image
2) Choose "'Set as Desktop Background...' --> Set Desktop Background dialog opens
3) Hit the 'Set Desktop Background' button --> image gets set as desktop background
(Reporter)

Comment 2

6 years ago
Strange, it doesn't work for me. I just tried again:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20121211 Firefox/20.0

Comment 3

6 years ago
At what step does it fail?
(Reporter)

Comment 4

6 years ago
After I hit 3) the image doesn't get set a the background of any of my monitors. The button is then replaced as 'Open Desktop Preferences' where none of the preview show the image anywhere.

Have you tried on a multi-monitor setup?

Comment 5

6 years ago
No, I just have a mini with one monitor.

You get the 'Open Desktop Preferences' label on the button. That means that browser/components/shell/content/setDesktopBackground.js#120 has changed the label on the button.

Maybe something goes wrong after browser/components/shell/src/nsMacShellService.cpp#245

Do you have the image somewhere on your hard drive, like in the 'Pictures" folder?
Component: Widget: Cocoa → Shell Integration
Product: Core → Firefox
(Reporter)

Comment 6

6 years ago
(In reply to Stefan [:stefanh] from comment #5)
> Do you have the image somewhere on your hard drive, like in the 'Pictures"
> folder?

Yes it's there.

Comment 7

6 years ago
I'm experiencing this as well. "Set Desktop Background" specifically fails on OSX when Firefox is in fullscreen mode.  Except, it's really not strictly a failure, it's just not working the way you expect. 

OSX both allows individual desktops to have their own backgrounds and creates a new temporary desktop when you put it to fullscreen it. So I'm guessing that Firefox correctly sets the background of a desktop you can't see and that disappears when it's taken out of fullscreen mode.
This was fixed by bug 1119088. I tested this with the image in comment 0, in fullscreen and non-fullscreen mode.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119088
You need to log in before you can comment on or make changes to this bug.