Very poor visual scrolling performance on Linux

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
6 years ago
2 months ago

People

(Reporter: michaelneil.nfld, Unassigned)

Tracking

18 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121129165634

Steps to reproduce:

- I have usually used Chromium since getting this PC in 2011. Firefox has always performed very poorly on this machine. It is not specific to the current Firefox version, distro, or drivers. 

- I have the same problem on every Linux distro I have tried, both live and installed. Swapping graphics cards (Radeon to NVIDIA) does nothing to help. It does not matter whether I am running the proprietary drivers or not.

- I have tried installing other versions, removing all Firefox data, and compiling a Nightly build myself. No change. 

- I have tried enabling/disabling hardware acceleration, smooth scrolling, etc. None have any influence on performance.

- No other programs have any issues like this, so it is definitely Firefox's problem.

- My PC is more than powerful enough to handle scrolling a webpage ;-)

- Currently I am running the 64 bit version of Ubuntu 12.04. This issue was present on previous Ubuntu releases, Fedora, and others as well.


Actual results:

- Very noticeable visual problems. Scrolling on any webpage is very jerky/laggy/jittery. It appears to be "stuttering".

- With smooth-scrolling enabled, the text sometimes flickers when scrolling.




Expected results:

Scrolling should be perfectly smooth, without any sign of stutter.

Updated

6 years ago
Component: Untriaged → Layout: View Rendering
Product: Firefox → Core

Comment 1

6 years ago
Reporter, can you reproduce this in safe mode (http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) or with a clean profile (http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles)? Could you also attach a screencast?
(Reporter)

Comment 2

6 years ago
Hi.

I've gotten the same results using a clean profile and safe mode. 

I did record a small screencast to demonstrate, but the desktop recorder adds too much lag to the video to make it of use. I'll see what else I can do in the meantime.

Comment 3

6 years ago
The same for me. Here's a firefox / chromium comparison: http://www.youtube.com/watch?v=vf7pbWQlS5s

I'm using KDE, Nvidia GeForce 7300GT with nvidia proprietary driver. I have tried no composition, XRender, OpenGL native and raster. I have also set nvidia-settings -a InitialPixmapPlacement=2 and forced layers acceleration in about:config. I recompiled cairo to include some improvements disabled for nvidia driver in archlinux: https://aur.archlinux.org/packages/cairo-nvidia/ I commented out ~/.gtkrc-2.0 as well. Nothing of this have helped (cairo I think improved the situation a little but not sure though...)
(Assignee)

Updated

2 months ago
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.