bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Homescreen][Everything.me] click on the link to background page source will eat home screen app

VERIFIED FIXED

Status

Firefox OS
Gaia::Homescreen
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: timdream, Assigned: crdlc)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

STR:

0. connect to wifi
1. on home screen, swipe left to Everything.me
2. select "Social" section, wait for the social apps and the nice kitties background to show up
3. swipe up, the icons will fade out, and there will be a Flickr link show up on the bottom
4. click the link

Expected:

1. open up the browser and show me the Flickr page


Actual:

1. home screen is being replaced by an external image
Hi Tim, do you have an image? not sure what the "external image" is. Thanks
Flags: needinfo?(timdream+bugs)
Couldn't reproduce this in triage
(Assignee)

Comment 3

6 years ago
:) I can reproduce it
(Assignee)

Updated

6 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Assignee: nobody → crdlc
(Assignee)

Comment 4

6 years ago
Created attachment 691311 [details]
Patch v1

Using view url activity
Attachment #691311 - Flags: review?(ran)
(Assignee)

Comment 5

6 years ago
IMHO it should be bb+ because of killing homescreen :)
(In reply to Joe Cheng from comment #1)
> Hi Tim, do you have an image? not sure what the "external image" is. Thanks

Sorry, on step 3 it should be swipe down (the opposite direction to reveal more icons)
Flags: needinfo?(timdream+bugs)
(Assignee)

Comment 7

6 years ago
Ran please put the r+  because you are agree with the minor change as you write in Github ;)
Attachment #691311 - Flags: review?(ran) → review+
Triage: I still can't reproduce this but if you can then taking over the homescreen is certainly blocking and is a regression.
blocking-basecamp: ? → +
Priority: -- → P2
(Assignee)

Comment 9

6 years ago
https://github.com/mozilla-b2g/gaia/commit/b401a32ec16e01104ae6b50e702cdeba2f719184
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 10

6 years ago
2012/28/01 build. Gecko-cfad7c9 Gaia-6c53dfd
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.