Failure in "MW0: Every app is successfully launched into the foreground"; Homescreen app fails to load

RESOLVED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia::System
P1
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cjones, Assigned: lightsofapollo)

Tracking

({regression})

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

STR
 (1) Follow the steps at https://wiki.mozilla.org/B2G/Memory_acceptance_criteria#MW0:_Every_app_is_successfully_launched_into_the_foreground_.5BPASS.5D
 (2) After step 18, the homescreen failed to load

Switching to a different app and back to homescreen, locking and unlocking the screen, repeatedly tapping where the homescreen should have been, failed to get it to reload.

Extremely bad bug.
No longer blocks: 820704
We're also failing "MW2: Active call stays active" because of this bug.
Guys, we need an owner of this.  This bricks the device until rebooting.
blocking-basecamp: --- → ?
Any idea what the regression that caused this is? Can we identify and backout asap?
Keywords: regression, regressionwindow-wanted
To Vivien for now, but awake time in CET is ending. Sent email to mgrs to see if we can assign PST & CST people.
Assignee: nobody → 21
James, can you start investigation on this one?
Assignee: 21 → jlal
blocking-basecamp: ? → +
Target Milestone: --- → B2G C3 (12dec-1jan)
(Assignee)

Comment 7

5 years ago
Sure I will shelf other stuff and start looking into this now.
(Assignee)

Comment 8

5 years ago
I was able to run though the MW0 case successfully with an eng otoro build from the 12-12 build. Going to try the mentioned build above to verify I can reproduce failure.
(Assignee)

Comment 9

5 years ago
On the 12-11 build it seems possible to reproduce the issue.
Upon investigating it seems like if the home screen is currently in the foreground then killed it cannot be restarted without rebooting the phone.

Its fairly easy to reproduce this by:

1. Unlocking the phone
2. Page to first set of apps
3. get pid (adb shell b2g-ps)
4. kill homescreen while it is in the foreground (adb shell kill $PID)
(Assignee)

Comment 10

5 years ago
Created attachment 692125 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7012

Pointer to Github pull-request
(Assignee)

Comment 11

5 years ago
Comment on attachment 692125 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7012

See github for comments. The STR I gave can be used to confirm if this works or not without going through the whole MW0 steps.
Attachment #692125 - Flags: review?(chris)
Attachment #692125 - Flags: review?(chris) → review?(timdream+bugs)
Comment on attachment 692125 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7012

r=me. I was having trouble understand your code due to diff output but read through it again I think it will work.
Attachment #692125 - Flags: review?(timdream+bugs) → review+
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Thanks for jumping on this, James!

Updated

5 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.