[Gaia] Make doesn't honor application type from the manifest

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: amac, Assigned: amac)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
When make creates the installed application database (webapps.json) it sets appStatus to 3 (certified) for all the apps included in the build. This is incorrect since apps can include a type attribute on their manifest that should be honored. And it can lead to inconsistencies since on some parts of the platform (like for actual permission granting) manifest.type is used where on other places appStatus is used instead.
(Assignee)

Comment 1

6 years ago
Created attachment 691281 [details]
Link to the 6968 PR

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #691281 - Flags: review?(fabrice)
Attachment #691281 - Flags: approval-gaia-master?(francisco.jordano)
Antonio - Does this happen with preloaded apps as well? Say the maps app?
(Assignee)

Comment 3

6 years ago
It does but that's another patch-in-process. Since they were only marginally related, after asking around I was recommended to file two separate bugs so they could be approved (or potentially rejected) separately. But, going back to your question, preloaded apps aren't correctly classified as installed either (since they don't get an appstatus they'll be marked as web instead wether they're really web or not). 

If you wish I'll update here when I file the second bug.
Attachment #691281 - Flags: review?(fabrice) → review+
Comment on attachment 691281 [details]
Link to the 6968 PR

a=me

this doesn't introduce any risk to the apps or the system, just fix the application registry making the manifest value for apps work.
Attachment #691281 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+
Landed

https://github.com/mozilla-b2g/gaia/commit/8fd956de06b7fe7d93298ac4b2d6bedf0c021d62
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 6

6 years ago
Device: Unagi
Build: 20130112070202
Does not reproduce at this time. Non issue
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 803814
You need to log in before you can comment on or make changes to this bug.