Last Comment Bug 820893 - mozilla.org/plugincheck needs fixed regarding java release as java says on the current release build
: mozilla.org/plugincheck needs fixed regarding java release as java says on th...
Status: RESOLVED WORKSFORME
:
Product: Websites
Classification: Other
Component: plugins.mozilla.org (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: Schalk Neethling [:espressive]
: Carsten Book [:Tomcat] - PTO-back Sept 4th
Mentors:
: 821247 821697 821893 (view as bug list)
Depends on:
Blocks: 821279
  Show dependency treegraph
 
Reported: 2012-12-12 09:01 PST by David Weir (satdav)
Modified: 2012-12-17 14:16 PST (History)
14 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description David Weir (satdav) 2012-12-12 09:01:37 PST
telling me i need to upgrade java

when i do upgrade the once i am running is the latest one from java website

Java Deployment Toolkit 7.0.90.5

Java(TM) Platform SE 7 U9
Comment 1 David Weir (satdav) 2012-12-12 09:05:22 PST
when i goto the plugincheck on nightly or firefox its telling me to update java to the latest build but when i goto the java site its saying i am on the latest build
Comment 2 Laura Thomson :laura 2012-12-12 09:09:32 PST
Schalk: I'm unclear if this is a plugincheck issue or a plugins.m.o issue.  Could you take a look?  ccing rhelmer as well, since he's worked on this a bit.
Comment 3 Tyler Downer [:Tyler] 2012-12-12 14:47:46 PST
Java.com isn't showing the newest update yet, you have to go to http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html to download. I think this is likely just waiting until java.com updates their plugin checker.
Comment 4 Schalk Neethling [:espressive] 2012-12-13 04:13:11 PST
Laura: Seems like a timing issue between the Oracle and the Java.com sites. The information returned from plugins.m.o is accurate but the information on the java.com site might be outdated leading to the confusion.

If the Oracle site is the one that is always up to date, then perhaps this is where we need to point people.

http://www.oracle.com/technetwork/java/javase/downloads/index.html

The only problem with this is that it might be confusing to general internet users, as they may not know whether to download the JRE or the JDK, so not an ideal solution.
Comment 5 Scoobidiver (away) 2012-12-13 05:04:22 PST
*** Bug 821247 has been marked as a duplicate of this bug. ***
Comment 6 Scoobidiver (away) 2012-12-14 07:10:56 PST
*** Bug 821697 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Versen [:Matti] 2012-12-14 15:01:08 PST
*** Bug 821893 has been marked as a duplicate of this bug. ***
Comment 8 Carsten Book [:Tomcat] - PTO-back Sept 4th 2012-12-15 04:38:06 PST
btw also java u10 is latest
Comment 9 Alice Wyman 2012-12-15 04:47:41 PST
(In reply to Schalk Neethling [:espressive] from comment #4)
> If the Oracle site is the one that is always up to date, then perhaps this
> is where we need to point people.
> 
> http://www.oracle.com/technetwork/java/javase/downloads/index.html
> 
> The only problem with this is that it might be confusing to general internet
> users, as they may not know whether to download the JRE or the JDK, so not
> an ideal solution.

Users are also confused about whether to select the x86 or x64 download, once they get to the list of available JRE downloads.  See: https://support.mozilla.org/en-US/questions/944267#answer-388705
Comment 10 Christian Riechers 2012-12-16 01:47:51 PST
The problem is not with Oracle or Java. It's FF 17.0.1 which flags Java 7U10 as outdated.
"For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version."
With FF on Windows the Java plugin doesn't even show up in the list of installed plugins for me.
With FF on Linux the same "Firefox has disabled ..." message is shown on the plugin check page. However, the Java plugin is at least visible in the list of plugins and can be enabled. Once enabled, FF shows it as up to date.
Java 7 U9 did work just fine on both, Windows and Linux.
Comment 11 Scoobidiver (away) 2012-12-16 02:47:24 PST
(In reply to Christian Riechers from comment #10)
> The problem is not with Oracle or Java. It's FF 17.0.1 which flags Java 7U10
> as outdated.
You hit bug 820759, not this bug which is about http://www.java.com/download/ not updated (linked to in plugincheck though).
Comment 12 Scoobidiver (away) 2012-12-17 14:16:48 PST
Java SE7 u10 is now proposed on java.com so I think we can close this bug as linking to http://www.oracle.com/technetwork/java/javase/downloads/index.html will create more problems than it will solve.

Note You need to log in before you can comment on or make changes to this bug.