Footer email form shouldn't submit on first click if closed

RESOLVED WORKSFORME

Status

www.mozilla.org
Bedrock
P3
normal
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: sgarrity, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
The footer email form in the mozilla.org template is 'closed' by default, hiding some of the form elements. Clicking in the email input or the submit button opens the rest of the form.

Clicking the submit button *also* submits the form, showing you errors. It probably shouldn't do that if the form wasn't open yet.
Steven, I believe this was fixed at some point or else I cannot reproduce. Can you verify or reopen if needed?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Priority: -- → P3
Resolution: --- → WORKSFORME
(Assignee)

Comment 2

5 years ago
This original issue is still there, but on second thought, it might not be so bad. Otherwise, clicking the submit button would open the form, but not provide any other feedback, which might be just as odd as showing the required field notices. Let's leave it as is.
Sidenote: the email input-field should really have a required attribute and aria-required="true"
You need to log in before you can comment on or make changes to this bug.