Moz Launched thru URL handler won't go to other typed in pages

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: wd, Assigned: neeti)

Tracking

({qawanted})

Trunk
mozilla1.2alpha
x86
Windows 98
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
BuildID:    2001052020

When Mozilla is launched through a "URL Handler" (I think that's what it's 
called), Mozilla launches OK, but the browser will refuse to go to any other 
URL typed in the URL box.   It will just re-load the current page.

Reproducible: Always
Steps to Reproduce:
1.Set up Mozilla to handle all URL's
2.Double-click on a URL in Eudora.   (Or other programs too, probably)
3.Once Mozilla loads up with that page, type in a new URL to go to

Actual Results:  mozilla re-loads the current page

Expected Results:  mozilla goes to the typed-in URL
(Assignee)

Updated

18 years ago
Keywords: qawanted
(Reporter)

Comment 1

18 years ago
I don't see this in 2001052204
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

18 years ago
When Mozilla is launched by clicking on a URL in another application, it fires 
up 2 windows.   (which is another filed bug I guess...)

One of these windows will accept new typed-in URL's.   The other will have the 
behavior described above.

Re-opening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 3

18 years ago
Can you specify how I should set up Mozilla to handle all URL's in step 1.
(Reporter)

Comment 4

18 years ago
I believe that system integration can be done via the Mozilla prefs, but It's
been a long time since I've done it.  (Advanced -> System)

If this doesn't do it, I have Mozilla set up as the default handler for:  URL:
HyperText Transfer Protocol.  (Done through Windows Explorer)

(Assignee)

Comment 5

18 years ago
I see only one window fire up, when mozilla is launched by clicking on a URL in 
another application.  And mozilla goes to the typed-in URL. This is with a winNT 
build from 5/30.
(Assignee)

Comment 6

18 years ago
marking WFM
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

18 years ago
It's not reproducible 100% of the time, but this sure still happens for me.
2001060220
re-opening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla0.9.3
(Assignee)

Updated

17 years ago
Priority: -- → P3
(Reporter)

Comment 8

17 years ago
*** Bug 87826 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
are you SURE you aren't seeing bug 83489? That just got fixed, so try a
2001-06-26 build

are you seeing any errors on the console?
(Reporter)

Comment 10

17 years ago
No, the behavior described here is this:

If I launch Moz to view a bug in bugzilla and I type in a new URL such as
www.google.com:

1) The Mozilla throbber animates
2) The statusbar says "resolving host bugzilla.mozilla.org", "Connecting to
bugzilla.mozilla.org",  etc...
3) The Bugzilla page re-loads.


the problem is intermittent, so I'm not totally sure if it's still happening

Comment 11

17 years ago
I have found that this seems to only occur on the FIRST instance of the Browser.
 If you CTRL+N for a new instance it does not seem to happen.

1. Load Mozilla.  (www.mozilla.org loads automatically or you home page for that
matter)
2. Press CTRL+L.
3. Enter a different address.  (Let's say for sake of argument www.linuxtoday.com)

You'll notice at the bottom it states "Resolving Host:  www.mozilla.org"
Mozilla then reloads the current page.
(Reporter)

Updated

17 years ago
Depends on: 59078

Comment 12

17 years ago
Scott, can you describe the starting point? Are you coming in from a Eudora link
or something else?

Comment 13

17 years ago
My problem was not associated with following a link.  I actually start the
program by double clicking the icon.  Mozilla loads www.mozilla.org as it's home
page.  I press CTRL+L to go to the URL Bar.  After I type my new location and
press enter, Mozilla says resolving www.mozilla.org and reloads the
www.mozilla.org index page.

I only saw this in the 20010625 build.  My particular issue may have been a
fluke of the daily build.

Comment 14

17 years ago
Can you test this w/ a new profile?
(Reporter)

Comment 15

17 years ago
I don't see this anymore.

Also, I've disabled DDE in my URL: HTTP handler in Win32 so that I don't get 2
browser windows upon clicking a URL.   I'm not sure if this is related.   ( bug
59078 )

Scott, if you don't either, this may be WFM

Comment 16

17 years ago
I haven't seen this issue in the latest builds I have been testing with.

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 17

17 years ago
I still see this.. it only happens in conjunction with bug 59078 I guess.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.6
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2

Comment 18

17 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
(Reporter)

Comment 19

17 years ago
WFM
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
Component: Networking → URL Bar
QA Contact: benc → claudius
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.