When using French , wifi network isn't detected

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Usul, Assigned: kaze)

Tracking

unspecified
B2G C3 (12dec-1jan)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
Last week I picked up a b2g phone (ZTE) and first thing I did was switch it to french.

I wanted to connect to my wifi at home and it never saw it. Today I switched back to english and ho miracle my wifi was now visible.

I have of course no log to show what the issue is/was.
Ludovic, is this 100% reproducible?
What happens if you use Portuguese as your language?
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 2

6 years ago
It was on first install. Didn't reset the phone to try in portugese.
And yes I tried to get wifi working at home fro 3 days. It started working when i switched back to english.
I think this should be tested by QA. First in French to see if this is reproducible and also in Portuguese to see if that language is also affected.

It seems weird that we have stuff broken because of the system language but if that's the case this is really scary because I doubt we have much testing in Portuguese...
blocking-basecamp: --- → ?
Keywords: qawanted
If this is first run only, possible dupe of bug 819947, leaving qawanted for now.
blocking-basecamp: ? → +
Whiteboard: DUPEME?

Updated

6 years ago
Assignee: nobody → mrbkap
This sounds like a UI bug. The Wifi code is hopefully (and likely) totally unaware of what locale we're in.

Still would like some QA input since wifi has been flaky so this might not be related to locales at all.
Assignee: mrbkap → nobody
Component: General → Gaia::First Time Experience
Testing with French during the first run, I am not able to reproduce this bug using the 2012128 Nightly Unagi build.

I also tested with Portuguese and I don't see the bug either using a freshly flashed new build.

But I have seen instances during testing (even today) where no wifi networks show during First Run.
QA Contact: mozillamarcia.knous
Ludovic, by any chance, does your wifi network (or any of your neighbors' networks) include UTF-8 characters in the SSID? If so, this might have had something to do with bug 819164.
Keywords: qawanted
No reason to believe this isn't a dupe of bug 819947. Please undupe if that changes.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819947
Duplicate of this bug: 823870
(In reply to Alex Keybl [:akeybl] from comment #8)
> No reason to believe this isn't a dupe of bug 819947. Please undupe if that
> changes.
> 
> *** This bug has been marked as a duplicate of bug 819947 ***

"And yes I tried to get wifi working at home fro 3 days." seems to be a good reason to think this has nothing to do with bug 819947 (according to bug 819947 comment 1, the other bug is about FTU only).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Component: Gaia::First Time Experience → Wifi
Whiteboard: DUPEME?
(Assignee)

Updated

6 years ago
Duplicate of this bug: 823874
(Assignee)

Comment 12

6 years ago
Ludovic, what’s your gecko build? By any chance, are you using the latest test-driver build (2012-12-06)?
(Assignee)

Updated

6 years ago
Assignee: nobody → kaze
(Assignee)

Comment 13

6 years ago
(either 2012-12-06 or 2012-12-12)
(Reporter)

Comment 14

6 years ago
(In reply to Fabien Cazenave [:kaze] from comment #13)
> (either 2012-12-06 or 2012-12-12)

2012-12-06 I haven't updated yet.
Target Milestone: --- → B2G C3 (12dec-1jan)
(Assignee)

Comment 15

6 years ago
I think this issue is specific to the 12/12/12 test-driver build. Can QA check this on a recent build please?
Keywords: qawanted
update?  has QA verified this?
Just checked using the 20121231 build - it was able to detect my home network fine using French. This is a freshly flashed build.

(In reply to Faramarz (:faramarz) from comment #16)
> update?  has QA verified this?
Keywords: qawanted
Closing as per #17.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
WORKSFORME without a specific cset known to have fixed it.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.