[SMS] Can't select certain messages in message deletion selection screen

VERIFIED FIXED in B2G C3 (12dec-1jan)

Status

Firefox OS
Gaia::SMS
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ypwalter, Assigned: michalbe)

Tracking

({regression})

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
*Phone: Unagi
2012-12-12
https://releases.mozilla.com/b2g/

*How to reproduce:
  0. send an message to phone A
  1. receive an message from phone A
  2. send an message to phone A
  3. click Edit icon on upper-right corner of messages screen
  4. try to select the incoming message

*Expected Result: 
    Incoming messages can be selected

*Actual Result:
    Incoming messages can't be selected

*note: only incoming messages after outgoing message can't be selected. also, please do notice that if you use select all, you can select them.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Triage: BB+, C3, P2- regression for broken feature
blocking-basecamp: ? → +
Keywords: regression
Priority: -- → P2
Target Milestone: --- → B2G C3 (12dec-1jan)
(Assignee)

Updated

5 years ago
Assignee: nobody → mbudzynski
(Assignee)

Comment 2

5 years ago
Created attachment 692098 [details]
patch
Attachment #692098 - Flags: review?(fernando.campo)
Hi [:michalbe] ! This bug is fixed in the following PR #6996 , due to applying new Building Blocks of Lists to SMS App, it is fixed automatically! So if you want, once the PR of BB was landed, we could retest it again and check that everything works as expected, Wdyt? Thanks for your work!
Depends on: 815260
Comment on attachment 692098 [details]
patch

Looks nice to me, but my understanding is that is gonna change whit the new building blocks

I'd like :borjasalguero to review it, cause he is the one taking care of SMS at the moment
Attachment #692098 - Flags: review?(fernando.campo) → review?(fbsc)
(Assignee)

Comment 5

5 years ago
It's a pity that you didn't checked it on Bz yesterday, I thought that noone is working on it. When do you expect your patch to land?
Im really sorry about it... I dind't realize that you were working on it :(. The bug is being reviewed and it's bb+, so I hope to have it ready asap! Again thanks for your work and sorry again for the missunderstanding.
(Assignee)

Comment 7

5 years ago
Np. I assume that you BBlocks patches will fix #821221 as well?
Nop! It's a problem that it's still reproducible with BB :(.
This one should be working due to BB are landed! Closing. If you find some issue with it, dont hesitate to reopen it. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

5 years ago
https://www.youtube.com/watch?v=3J-5SyaU2GM

It can still be reproduced.
The selection of messages kind of working.
However, the offset is a little bit off for some reasons

As you see in the video, if you clicked in right checkbox, it won't react.
If you click a little bit off, it works sometimes.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

5 years ago
:borjasalguero Maybe we can try my fix now if you'll confirm that your's not working?
[:michalbe] Please Gaia version
(Assignee)

Comment 13

5 years ago
I don't think I understand what do you mean.
Probably asking for build/gaia version the test has been made with, so my guess is that the question was really pointed at Walter Chen instead of you Michał
Flags: needinfo?(wachen)
[:michalbe] My fault, I was trying to ask Walter about the Gaia/Gecko version.
(Reporter)

Comment 16

5 years ago
https://releases.mozilla.com/b2g/
2012-12-12 build
Flags: needinfo?(wachen)
Hi Walter, 
This is a quite old version, could you try again with a most recent one? Because this issue was fixed some days ago, and your version is so old. Thanks!
(Reporter)

Comment 18

5 years ago
This bug happened in 2012-12-12. Even if this issue goes away, we still need to know what happened, right?

I tried it on  2012-12-19 18:49:40 PST with most recently build (2012-12-18 build). And, it still kind of reproducible in another way which I stated in comment 10. I attached the video. Did you looked at my comment first, think about it, and then ask me for info? Please do take a careful look on my original post and my following comment.
(Assignee)

Comment 19

5 years ago
whats the status of this one now? Anyone working on it?
Attachment #692098 - Flags: review?(fbsc)
With the following (2012-12-23 Build and latest Gaia):
Gaia revision:"e790b7f4ff82cbd3c01297bc30c31b7fccc07ecb"
Gecko revision:"bae67f29dfa16eb7d3904b8bfabd87099d4a52d2"

Is not reproducible. Probably your build did not contain the patch https://github.com/mozilla-b2g/gaia/pull/6996 due to was landed in master 2012-12-17 and your Build was 2012-12-18 build. I've recorded a video with the commits added above and you can see the result. I've tested as well clicking inside/outside the checkbox, and it's working properly due to the whole area is clickable. Please could you try again? Thanks a lot! And sorry for the misunderstandings, sometimes it's hard to reproduce the bug of check if it's fixed because the build versions.

Video:
http://youtu.be/j_fqDlnugyw
Flags: needinfo?(wachen)
Duplicate of this bug: 823358
(Reporter)

Comment 22

5 years ago
Hi, I think it is fixed and verified as for 2012-12-23 build from https://releases.mozilla.com/b2g/. 

Verified fixed
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(wachen)
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.