The virtual keyboard is dismissed on first match when using Find in Page

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: AdrianT, Assigned: jchen)

Tracking

({regression, reproducible})

20 Branch
Firefox 20
ARM
Android
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18 unaffected, firefox19 unaffected, firefox20 verified)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
Nightly 20.0a1 2012-12-12
Samsung Galaxy Tab 2 7.0 (Android 4.0.4)

Steps to reproduce:
1) Go to any web page
2) Open Find in Page and start typing a search term

Expected results:
The first word matching the search is highlighted but the keyboard is dismissed only when the user taps the next arrow

Actual results:
The keyboard is dismissed on first match, even on the first letter entered match

Notes:
Issue is not reproducible on Aurora or Beta.
Reporter

Updated

7 years ago
Summary: The virtual keyboard is dismissed on first match → The virtual keyboard is dismissed on first match when using Find in Page
Bug 760087 all over again?

See old patch: https://bugzilla.mozilla.org/attachment.cgi?id=630766&action=diff

Jim, is this a regression from bug 815430, or your re-write?
Assignee: nobody → nchen
This is as intended
Status: NEW → RESOLVED
tracking-fennec: ? → -
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
This was mis-interpreted and is not working as intended. The keyboard is dismissed far too early here and is a regression.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
tracking-fennec: - → ?
Duplicate of this bug: 822043
Status: REOPENED → NEW
Version: Trunk → Firefox 20
Last good: 20121205
First bad: 20121206
Find In Page can cause focus changes and corresponding notifyIMEEnabled calls, which make us show/hide the keyboard. This patch checks whether the Gecko view has focus first before showing/hiding the keyboard. When Find In Page is active the focus is on the find text field, so we end up not showing/hiding the keyboard unintentionally.
Attachment #693129 - Flags: review?(cpeterson)
Comment on attachment 693129 [details] [diff] [review]
Don't show/hide VKB when Gecko view doesn't have focus (v1)

Review of attachment 693129 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM

::: mobile/android/base/GeckoInputConnection.java
@@ +519,5 @@
>  
> +        View v = getView();
> +        if (v == null || !v.hasFocus()) {
> +            return;
> +        }

Please add a brief comment describing how this check handles "Find In Page" focus bug.
Attachment #693129 - Flags: review?(cpeterson) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/d2ee611a3e23
Blocks: 815430
No longer blocks: 811755
Status: NEW → ASSIGNED
Flags: in-testsuite-
Target Milestone: --- → Firefox 20
https://hg.mozilla.org/mozilla-central/rev/d2ee611a3e23
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 11

7 years ago
Firefox 20.0a1 (2012-11-19)
Device: Galaxy Nexus
OS: Android 4.1.1 

This is not reproducible following steps mentioned in Comment#1 on latest Nightly. Marking bug as VERIFIED FIXED.
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.