ftp gz files are automatically gunziped

VERIFIED DUPLICATE of bug 35956

Status

()

VERIFIED DUPLICATE of bug 35956
18 years ago
18 years ago

People

(Reporter: f300v10, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; rv:0.9+)
Gecko/20010521
BuildID:    2001052106

Starting early last week all *.tar.gz files I download are automagically being
gunzip-ed.  I am seeing this on both my linux boxes, and don't recall setting
anything in my profile that would account for this.  The files retain the
*.tar.gz extention, but are really *.tar files when the download completes.

When I download the latest nightly, the download size from the network is 9.2M,
but the file is over 23M on disk.  If I try 'tar -xzvf *.gz' it fails, saying it
is not a gz file.  But 'tar -xvf *.gz' works fine and extracts the contents of
the tar file.

Reproducible: Always
Steps to Reproduce:
1.Ftp a *.tar.gz file
2.
3.

Actual Results:  File is downloaded and automatically gunzip-ed.

Expected Results:  File should not gunzip

I also just tried this with a brand new profile, and got the same result.  The
downloaded file was 23+M.

Comment 1

18 years ago
Is this different from Bug 35956?
(Reporter)

Comment 2

18 years ago
This is indeed a dup of 35956.

*** This bug has been marked as a duplicate of 35956 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.