precompile_cache.js is timing out on elm nightly builds

RESOLVED DUPLICATE of bug 780561

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 780561
6 years ago
4 months ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Both nightly builds from last night. Seems like it might be a new packager issue?

e:\builds\moz2_slave\elm-w64-ntly\build\toolkit\mozapps\installer\packager.mk:571:0$ e:/builds/moz2_slave/elm-w64-ntly/build/obj-firefox/_virtualenv/Scripts/python.exe e:/builds/moz2_slave/elm-w64-ntly/build/toolkit/mozapps/installer/packager.py -DNO_NSPR_10_SUPPORT -DAB_CD=en-US -DMOZ_APP_NAME=firefox -DPREF_DIR=defaults/preferences -D_MSC_VER=1600 -DJAREXT= -DMOZ_ANGLE_RENDERER=1 -DMOZ_D3DX9_DLL=d3dx9_43.dll -DMOZ_D3DCOMPILER_DLL=D3DCompiler_43.dll -DMOZ_CHILD_PROCESS_NAME=plugin-container.exe -DMOZ_MSVC_REDIST=1600 -DMOZ_SHARED_MOZGLUE=1 -DMOZ_JSDEBUGGER -DNECKO_WIFI -DDLL_PREFIX= -DDLL_SUFFIX=.dll -DBIN_SUFFIX=.exe -DBINPATH=bin \
	--format omni \
	--removals e:/builds/moz2_slave/elm-w64-ntly/build/browser/installer/removed-files.in \
	 \
	 \
	--jarlogs e:/builds/moz2_slave/elm-w64-ntly/build/obj-firefox/browser/installer/../../jarlog//en-US \
	 \
	package-manifest ../../dist ../../dist/firefox
Executing e:/builds/moz2_slave/elm-w64-ntly/build/obj-firefox/dist\bin\xpcshell.exe -g e:\builds\moz2_slave\elm-w64-ntly\build\obj-firefox\dist\bin/ -a e:\builds\moz2_slave\elm-w64-ntly\build\obj-firefox\dist\bin/browser -f e:/builds/moz2_slave/elm-w64-ntly/build/toolkit/mozapps/installer\precompile_cache.js -e precompile_startupcache("resource://app/");

command timed out: 10800 seconds without output, attempting to kill
I think it's a PGO problem. The previous new packager wasn't running cache precompilation and couldn't have hit the problem.
(Assignee)

Comment 2

6 years ago
Just running in a regular build, everything seems to work as expected:


$ ./dist/bin/xpcshell.exe -g F:/Mozilla/firefox/ELM-REL/dist/bin/ -a F:/Mozilla/firefox/ELM-REL/dist/bin/browser -f F:/Mozilla/firefox/elm/toolkit/mozapps/installer/precompile_cache.js -e "precompile
_startupcache('resource://app/')"

resource://app/components/ChromeProfileMigrator.js
resource://app/components/DownloadsStartup.js
resource://app/components/DownloadsUI.js
resource://app/components/FeedConverter.js
resource://app/components/FeedWriter.js
resource://app/components/FirefoxProfileMigrator.js
resource://app/components/fuelApplication.js
resource://app/components/IEProfileMigrator.js
resource://app/components/nsBrowserContentHandler.js
resource://app/components/nsBrowserGlue.js
resource://app/components/nsPrivateBrowsingService.js
resource://app/components/nsSessionStartup.js
resource://app/components/nsSessionStore.js
resource://app/components/nsSetDefaultBrowser.js
resource://app/components/nsSidebar.js
resource://app/components/PageThumbsProtocol.js
resource://app/components/PlacesProtocolHandler.js
resource://app/components/ProfileMigrator.js
resource://app/components/SafariProfileMigrator.js
resource://app/components/WebContentConverter.js
resource://app/modules/devtools/TiltWorkerCrafter.js
resource://app/modules/devtools/TiltWorkerPicker.js
resource://app/modules/distribution.js
resource://app/modules/PageThumbsWorker.js
resource://app/modules/AboutHomeUtils.jsm
resource://app/modules/AutocompletePopup.jsm
resource://app/modules/BrowserNewTabPreloader.jsm
resource://app/modules/devtools/Breadcrumbs.jsm
resource://app/modules/devtools/Browser.jsm
resource://app/modules/devtools/CmdAddon.jsm
resource://app/modules/devtools/CmdBreak.jsm
resource://app/modules/devtools/CmdCalllog.jsm
resource://app/modules/devtools/CmdCalllogChrome.jsm
resource://app/modules/devtools/CmdCmd.jsm
resource://app/modules/devtools/CmdConsole.jsm
resource://app/modules/devtools/CmdCookie.jsm
resource://app/modules/devtools/CmdDbg.jsm
resource://app/modules/devtools/CmdEcho.jsm
resource://app/modules/devtools/CmdEdit.jsm
resource://app/modules/devtools/CmdExport.jsm
resource://app/modules/devtools/CmdInspect.jsm
resource://app/modules/devtools/CmdJsb.jsm
resource://app/modules/devtools/CmdPagemod.jsm
resource://app/modules/devtools/CmdResize.jsm
resource://app/modules/devtools/CmdRestart.jsm
resource://app/modules/devtools/CmdScratchpad.jsm
resource://app/modules/devtools/CmdScreenshot.jsm
resource://app/modules/devtools/CmdTilt.jsm
resource://app/modules/devtools/Commands.jsm
resource://app/modules/devtools/CssHtmlTree.jsm
resource://app/modules/devtools/CssLogic.jsm
resource://app/modules/devtools/CssRuleView.jsm
resource://app/modules/devtools/DebuggerPanel.jsm
resource://app/modules/devtools/DebuggerUI.jsm
resource://app/modules/devtools/DeveloperToolbar.jsm
resource://app/modules/devtools/DOMHelpers.jsm
resource://app/modules/devtools/EventEmitter.jsm
resource://app/modules/devtools/FloatingScrollbars.jsm
resource://app/modules/devtools/gcli.jsm
resource://app/modules/devtools/gDevTools.jsm
resource://app/modules/devtools/Highlighter.jsm
resource://app/modules/devtools/InspectorPanel.jsm
resource://app/modules/devtools/Jsbeautify.jsm
resource://app/modules/devtools/LayoutHelpers.jsm
resource://app/modules/devtools/MarkupView.jsm
resource://app/modules/devtools/responsivedesign.jsm
resource://app/modules/devtools/scratchpad-manager.jsm
resource://app/modules/devtools/Selection.jsm
resource://app/modules/devtools/Sidebar.jsm
resource://app/modules/devtools/SplitView.jsm
resource://app/modules/devtools/StyleEditor.jsm
resource://app/modules/devtools/StyleEditorChrome.jsm
resource://app/modules/devtools/StyleEditorPanel.jsm
resource://app/modules/devtools/StyleEditorUtil.jsm
resource://app/modules/devtools/StyleInspector.jsm
resource://app/modules/devtools/Target.jsm
resource://app/modules/devtools/Templater.jsm
resource://app/modules/devtools/Tilt.jsm
resource://app/modules/devtools/TiltGL.jsm
resource://app/modules/devtools/TiltMath.jsm
resource://app/modules/devtools/TiltUtils.jsm
resource://app/modules/devtools/TiltVisualizer.jsm
resource://app/modules/devtools/TiltVisualizerStyle.jsm
resource://app/modules/devtools/Toolbox.jsm
resource://app/modules/devtools/ToolboxHosts.jsm
resource://app/modules/devtools/ToolDefinitions.jsm
resource://app/modules/devtools/Undo.jsm
resource://app/modules/devtools/VariablesView.jsm
resource://app/modules/DownloadsCommon.jsm
resource://app/modules/HUDService.jsm
resource://app/modules/KeywordURLResetPrompter.jsm
resource://app/modules/MigrationUtils.jsm
resource://app/modules/NetworkPanel.jsm
resource://app/modules/NetworkPrioritizer.jsm
resource://app/modules/NewTabUtils.jsm
resource://app/modules/offlineAppCache.jsm
resource://app/modules/openLocationLastURL.jsm
resource://app/modules/PageThumbs.jsm
resource://app/modules/PlacesUIUtils.jsm
resource://app/modules/PropertyPanel.jsm
resource://app/modules/RecentWindow.jsm
resource://app/modules/sessionstore/DocumentUtils.jsm
resource://app/modules/sessionstore/SessionStorage.jsm
resource://app/modules/sessionstore/SessionStore.jsm
resource://app/modules/sessionstore/XPathGenerator.jsm
resource://app/modules/SharedFrame.jsm
resource://app/modules/SignInToWebsite.jsm
resource://app/modules/Social.jsm
resource://app/modules/source-editor-orion.jsm
resource://app/modules/source-editor-ui.jsm
resource://app/modules/source-editor.jsm
resource://app/modules/tabview/utils.jsm
resource://app/modules/TelemetryTimestamps.jsm
resource://app/modules/webappsUI.jsm
resource://app/modules/WebConsolePanel.jsm
resource://app/modules/webrtcUI.jsm
resource://app/modules/WindowsJumpLists.jsm
resource://app/modules/WindowsPreviewPerTab.jsm
(Assignee)

Comment 3

6 years ago
Building a local pgo build. Hopefully I'll see the timeout and can debug.
(Assignee)

Comment 4

6 years ago
This is some sort of a path issues, xpcshell throws up

win error dialog: The program can't start because pgort100.dll is missing from your computer. 

which is in the msvc10/vc/bin folder. But for some reason it's not being found.
(Assignee)

Comment 5

6 years ago
Hrm, the same manual call to xpcshell works fine at the same point in the build. Really strange.

(Note You have to have MOZ_PGO_INSTRUMENTED=1 exported in your shell or xpcshell will crash.)
(Assignee)

Comment 6

6 years ago
Created attachment 692311 [details] [diff] [review]
fix

Missing environment when launching stuff from packger.py. This fixes the problem in a local pgo build.
Assignee: nobody → jmathies
Attachment #692311 - Flags: review?(mh+mozilla)
Attachment #692311 - Flags: review?(mh+mozilla) → review+
I'll integrate something in the new packager interation.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780561

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.