Calling openUILinkIn from PlacesUIUtils.jsm _openNodeIn fails when where = "save"

RESOLVED FIXED in Firefox 20

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: tabmix.onemen, Assigned: mak)

Tracking

({regression})

Trunk
Firefox 20
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
1. set browser.altClickSave to true
2. Alt+click (enter) from bookmarks sidebar or library

result after bug 814264 landed:
"openUILink/openLinkIn was called with "where == 'save' but without initiatingDoc.  See bug 814264."

result before bug 814264 landed:
saveURL not defined
(Assignee)

Comment 1

6 years ago
it's likely this code needs to be updated to properly pass the document.
(Assignee)

Updated

6 years ago
Component: General → Bookmarks & History
(Assignee)

Updated

6 years ago
Assignee: nobody → mak77
(Assignee)

Comment 2

6 years ago
I'm taking this just to have it on the radar, if you want to make a patch feel free to take it.
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
Keywords: regression
(Assignee)

Comment 3

6 years ago
so, this was already not working (since it's trying to use saveURL but the sidebar doesn't have contentAreaUtils) and it is still not working (now throws), likely not worth to track, considered it's also enabled through a non-default pref.
(Assignee)

Comment 4

6 years ago
the original bug about "saveURL not defined" is bug 451658
tracking-firefox18: ? → ---
tracking-firefox19: ? → ---
tracking-firefox20: ? → ---
(Assignee)

Comment 5

6 years ago
Created attachment 691961 [details] [diff] [review]
patch v1.0

and I think this is the proper patch to fix both bugs, just ignore alt. alt+click was intended for content links, not for chrome.
(Assignee)

Updated

6 years ago
Attachment #691961 - Flags: review?(dao)
(Assignee)

Updated

6 years ago
Blocks: 451658
Attachment #691961 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/f0b590fbfd9f
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.