Closed Bug 821383 Opened 9 years ago Closed 9 years ago

Don't bother with JSAPI magic in nsHTMLMediaElement::{G,S}etMozSrcObject

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla22

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Details

Attachments

(1 file)

Attached patch Patch v1Splinter Review
No description provided.
Attachment #691886 - Flags: review?(bzbarsky)
Comment on attachment 691886 [details] [diff] [review]
Patch v1

Looks ok to me, but check with roc that the "silently ignore other objects" behavior is not by design?
Attachment #691886 - Flags: review?(roc)
Attachment #691886 - Flags: review?(bzbarsky)
Attachment #691886 - Flags: review+
I actually want to extend this attribute so a Blob can be assigned too, and maybe other objects eventually. So, I think we should not do this.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #2)
> I actually want to extend this attribute so a Blob can be assigned too, and
> maybe other objects eventually. So, I think we should not do this.

We'll be on webidl bindings long before this happens, so I think we should land this.
Comment on attachment 691886 [details] [diff] [review]
Patch v1

Review of attachment 691886 [details] [diff] [review]:
-----------------------------------------------------------------

Fair enough.
Attachment #691886 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/103a7bbcf074
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.