Closed Bug 821455 Opened 7 years ago Closed 7 years ago

Call forwarding does not work as expected.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86
macOS
defect
Not set

Tracking

(blocking-basecamp:-)

RESOLVED DUPLICATE of bug 824801
blocking-basecamp -

People

(Reporter: liuche, Unassigned)

References

Details

(Keywords: b2g-testdriver, unagi)

Attachments

(2 files)

Parts of call forwarding do not work. (12/12/12 nightly build)

a. "Forward when unanswered" does not forward calls. Calls go directly to voicemail.
b. Unable to save changes to "Always Forward" submenu - after toggling to enable  or adding a phone number in submenu, changes are not persisted. (screenshot 1)
c. Changing # for forwarding (e.g., "Forward when unanswered") does not get reflected in Call Settings menu - number is the same as before. (screenshot 1)
d. Text is cut off and overlaps with toggle button in submenu of "Forward when unanswered" and "Forward when unreachable". (screenshot 2)
e. Forwarding number should not be set by default. (screenshot 1)
Depends on: 803533
Additionally, the call-forwarding icon in the notifications bar doesn't necessarily reflect the current toggle state of call forwarding in Call Settings; additional toggling is necessary to clear it.

STR:
1. Toggle "Always Forward" to activated in Settings > Call Settings > Always Forward.
2. Hit back. Call forwarding icon is present in notifications bar.

Expected:
"Always Forward" state should read "Enabled"

Actual:
"Always Forward" state is always "Disabled". To clear the call forwarding icon, you must toggle the "Always Forward" state from disabled > enabled > disabled again.
We are dealing with all these issues on bug 819009. WIP is at https://github.com/jaoo/gaia/tree/819009.
Depends on: 819009
Duplicate of this bug: 824410
blocking-basecamp: --- → ?
bug 824801 is the meta bug for call forwarding -- duping this.
Status: NEW → RESOLVED
blocking-basecamp: ? → -
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: CF-UI
If the dependencies of bug 824801 are not complete, please file separate specific bugs and tie them to that issue.
You need to log in before you can comment on or make changes to this bug.