keyboard overwrites don't work because of typo

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:-)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Just a silly key name title. I tested this on a desktop build:
https://github.com/mozilla-b2g/gaia/pull/7006
(Assignee)

Comment 1

5 years ago
To make this easier to review, here's the code that interprets this, showing it looking for "textLayoutOverwrites": https://github.com/mozilla-b2g/gaia/blob/master/apps/keyboard/js/keyboard.js#L628
(Assignee)

Comment 2

5 years ago
Created attachment 693358 [details] [diff] [review]
fix the typo

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #693358 - Flags: review?(kaze)
(Assignee)

Comment 3

5 years ago
Created attachment 693366 [details] [diff] [review]
use textLayoutOverwrite everywhere

This fixes other keyboards too. Good catch!
Attachment #693358 - Attachment is obsolete: true
Attachment #693358 - Flags: review?(kaze)
Attachment #693366 - Flags: review?(kaze)
(Assignee)

Updated

5 years ago
Summary: dvorak keyboard overwrites don't work because of typo → keyboard overwrites don't work because of typo
Attachment #693366 - Flags: review?(kaze) → review+
blocking-basecamp: --- → ?
Attachment #693366 - Flags: approval-gaia-master+
blocking-basecamp: ? → -
https://github.com/mozilla-b2g/gaia/commit/c679286be4e0d99ec40c7be0abd961779daa056f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.