Graphic buffer errors on boot screen

RESOLVED WORKSFORME

Status

Firefox OS
General
P1
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: diego, Assigned: mwu)

Tracking

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 692009 [details]
Logcat log

During the boot screen I can see the error messages below repeated several times:

E/libgenlock(  125): perform_lock_unlock_operation: GENLOCK_IOC_DREADLOCK failed (lockType0x1, err=Connection timed out fd=15)
W/Adreno200-EGLSUB(  125): <GetBackBuffer:2125>: genlock_lock_buffer GENLOCK_WRITE_LOCK failed
W/Adreno200-EGL(  125): <qeglDrvAPI_eglSwapBuffers:3476>: EGL_BAD_ALLOC
E/libgenlock(  125): perform_lock_unlock_operation: GENLOCK_IOC_DREADLOCK failed (lockType0x1, err=Connection timed out fd=15)

See full log attached
(Reporter)

Updated

5 years ago
Blocks: 808607
(seems to be related to the new bootanimation.zip support that was added to Gecko recently)
blocking-basecamp: --- → ?
If the errors are not visible on screen it doesn't seem that this issue is critical enough to block. Can you comment on why this issue is severe enough to block?
Genlock errors like this are typically very serious and imply something very broken about how EGL/GLES is being used.  This is a stability issue that needs to resolved to successfully commercialize the platform.
Blocking per comment #3. If investigation shows it's not actually blocking we can flip the flag back.
Assignee: nobody → mwu
blocking-basecamp: ? → +
Priority: -- → P1
Target Milestone: --- → B2G C3 (12dec-1jan)
(Assignee)

Comment 5

5 years ago
I don't remember seeing this on unagi.

m1, does the boot animation work on your device?
Flags: needinfo?(mvines)
Yeah it works.  I've seen this a couple times on Otoro.  It's not 100% though
Flags: needinfo?(mvines)
(Assignee)

Comment 7

5 years ago
Ok that helps, thanks for the info. I'll see if I can fix this.
Any update on a fix for this, mwu?
(Assignee)

Comment 9

5 years ago
The boot animation code doesn't seem to work on otoro. I'll fix it and see if I can reproduce this bug.
(Assignee)

Comment 10

5 years ago
I posted a patch to fix the boot animation on otoro to bug 824090.

However, I still can't reproduce the genlock errors on otoro, unagi, or m4. If I reboot the phone 6-7 times, should I expect to see it?

I'm testing against trunk but the boot animation code on trunk and branch is identical AFAIK.

m1, do you have any other ideas? I don't think we can block if we can't reproduce..
Flags: needinfo?(mvines)
I can no longer reproduce at the tip.  Maybe the fix for bug 824090 helped, or maybe a mystery fix.  Will reopen this bug if it comes back I guess.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mvines)
Resolution: --- → WORKSFORME
I am getting this, from a new port of Firefox OS on my Qualcomm 8225Q based phone. (K-touch Kiss U86). I was trying to port Firefox OS on my device, but the screen remains blank and the logcat is:

....
W/Adreno200-EGL(  450): <qeglDrvAPI_eglSwapBuffers:3508>: EGL_BAD_ALLOC
E/libgenlock(  450): perform_lock_unlock_operation: handle is invalid
W/Adreno200-EGLSUB(  450): <GetBackBuffer:2180>: genlock_lock_buffer GENLOCK_WRITE_LOCK failed
W/Adreno200-EGL(  450): <qeglDrvAPI_eglSwapBuffers:3508>: EGL_BAD_ALLOC
E/libgenlock(  450): perform_lock_unlock_operation: handle is invalid
W/Adreno200-EGLSUB(  450): <GetBackBuffer:2180>: genlock_lock_buffer GENLOCK_WRITE_LOCK failed
W/Adreno200-EGL(  450): <qeglDrvAPI_eglSwapBuffers:3508>: EGL_BAD_ALLOC
E/libgenlock(  450): perform_lock_unlock_operation: handle is invalid
W/Adreno200-EGLSUB(  450): <GetBackBuffer:2180>: genlock_lock_buffer GENLOCK_WRITE_LOCK failed
W/Adreno200-EGL(  450): <qeglDrvAPI_eglSwapBuffers:3508>: EGL_BAD_ALLOC
E/libgenlock(  450): perform_lock_unlock_operation: handle is invalid
W/Adreno200-EGLSUB(  450): <GetBackBuffer:2180>: genlock_lock_buffer GENLOCK_WRITE_LOCK failed
....
(In reply to Aniruddha Adhikary from comment #12)
> I am getting this, from a new port of Firefox OS on my Qualcomm 8225Q based
> phone. (K-touch Kiss U86). I was trying to port Firefox OS on my device, but
> the screen remains blank and the logcat is:

It might be better to disable gralloc during porting. You can disable gralloc by changing the following code if you are using recent master gecko.
 http://mxr.mozilla.org/mozilla-central/source/gfx/layers/client/CompositableClient.cpp#204

If you are using older gecko, you can disable gralloc by changin the following code.
http://mxr.mozilla.org/mozilla-central/source/gfx/layers/ipc/ShadowLayerUtilsGralloc.cpp#436
FYI. The following link has some information about gralloc.
https://wiki.mozilla.org/Platform/GFX/Gralloc
You need to log in before you can comment on or make changes to this bug.