[Updates] Downloading updates goes above and beyond the file size of the announced update

RESOLVED DUPLICATE of bug 814612

Status

Firefox OS
Gaia::System
P3
normal
RESOLVED DUPLICATE of bug 814612
5 years ago
5 years ago

People

(Reporter: lsblakk, Assigned: etienne)

Tracking

({b2g-testdriver, unagi})

unspecified
x86
Mac OS X
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

Created attachment 692045 [details]
screenshot of 120+MB update download status

Mark hit this problem today, he initiated an update installation that was announced at ~57MB (normal update) and then watched as it climbed in download size to over 120MB - never completing.  See screenshot

Comment 1

5 years ago
It stopped at 129.78 MB but just spun there. I cancelled the update, then tried again, but it didn't download anything, just stayed at 0 MB. I then restarted the phone, and it didn't find an update at all, just stayed at "Looking for updates". Finally, I restarted it again, and now it says I'm on build 20121212102240...

Updated

5 years ago
Component: Gaia → Gaia::System
This also happened to me, I also observed the Data Usage app in parallel and I think the OTA counter is counting more data than what is actually downloaded.
Assignee: nobody → etienne
blocking-basecamp: ? → +
Priority: -- → P3
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814612
(Assignee)

Comment 4

5 years ago
(In reply to Mark Côté ( :mcote ) from comment #1)
> It stopped at 129.78 MB but just spun there. I cancelled the update, then
> tried again, but it didn't download anything, just stayed at 0 MB. I then
> restarted the phone, and it didn't find an update at all, just stayed at
> "Looking for updates". Finally, I restarted it again, and now it says I'm on
> build 20121212102240...

Thank you, very very much!
I was able to reproduce exactly this so now I have something to chew on.
You need to log in before you can comment on or make changes to this bug.