"Assertion failure: !InNoGCScope(),"

VERIFIED FIXED in mozilla20

Status

()

--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: gkw, Assigned: terrence)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
mozilla20
x86_64
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:update])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 692108 [details]
stack

function g() {
    z = newGlobal('');
    return function(code) {
        evalcx(code, z)
    }
}
f = g();
f("\
    options('strict_mode');\
    for (var x = 0; x < 1; ++x) {\
        a = x;\
    }\
    options('strict_mode');\
");
f("a in eval");


asserts js debug shell on m-c changeset 020555b69f72 with --ion-eager at Assertion failure: !InNoGCScope(),

autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   115711:9602f98a6a70
user:        Terrence Cole
date:        Wed Dec 05 14:21:44 2012 -0800
summary:     Bug 819118 - Use accessor rather than direct script access; r=billm
(Assignee)

Comment 1

6 years ago
Created attachment 692114 [details] [diff] [review]
v0

I went ahead and just made the relevant methods take Handles and Unrooted this time, I'm not sure why I didn't last time.
Assignee: general → terrence
Status: NEW → ASSIGNED
Attachment #692114 - Flags: review?(wmccloskey)
Comment on attachment 692114 [details] [diff] [review]
v0

Review of attachment 692114 [details] [diff] [review]:
-----------------------------------------------------------------

Let's do this to fix the assertion, but we should do the SuppressGC thing soon.
Attachment #692114 - Flags: review?(wmccloskey) → review+

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/4fb4bbc6b029
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
(Reporter)

Updated

6 years ago
Flags: in-testsuite+
(Reporter)

Comment 5

6 years ago
A type of test for this bug has already been landed because it is already marked in-testsuite+ -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.