[Clock] Cannot reset the first-added alarm.

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Gene Lian (I already quit Mozilla), Assigned: schien)

Tracking

({regression})

unspecified
B2G C3 (12dec-1jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
STR:
====================
  0. 2012/12/14 mozilla-central build.
  1. Add a new alarm and save it.
  2. Reset that alarm.

Actual:
====================
  It has no reaction when tapping it.

Expected:
====================
  It should go into the time picker page.

Note:
====================
  This is not bug 821583.
(Reporter)

Comment 1

6 years ago
Nominate for bb+ because users cannot reset their alarm. Need to fix it!
blocking-basecamp: --- → ?
(Reporter)

Comment 2

6 years ago
(In reply to Gene Lian [:gene] from comment #0)
> Expected:
> ====================
>   It should go into the time picker page.

You can go into it by the second tap (the first tap only higtlight it).
(Reporter)

Comment 3

6 years ago
(In reply to Gene Lian [:gene] from comment #2)
> (In reply to Gene Lian [:gene] from comment #0)
> > Expected:
> > ====================
> >   It should go into the time picker page.
> 
> You can go into it by the second tap (the first tap only higtlight it).

After more investigations and having discussing with :schien, we found out it doesn't matter with the first tap or second tap. Actually, it depends on how you touch the screen. If you tap it with a little slide then it fails. If you tap it with very quick touch then it succeeds.

Some regression might happen by the recent scroll event change.
(Reporter)

Updated

6 years ago
Keywords: regression
(Reporter)

Updated

6 years ago
Component: Gaia::Clock → General
QA Contact: jshih
I'll take further investigation on this bug.
Assignee: nobody → schien
Component: General → Gaia::Clock
QA Contact: jshih
blocking-basecamp: ? → +
Component: Gaia::Clock → General
QA Contact: jshih

Updated

6 years ago
Target Milestone: --- → B2G C3 (12dec-1jan)
I cannot reproduce this issue after bug 814252 been backout.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.