If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Playing Piranhas reproducibly crashes Fennec 18 in js::ion::Cannon

REOPENED
Assigned to

Status

()

Core
JavaScript Engine
--
critical
REOPENED
5 years ago
5 years ago

People

(Reporter: Yoric, Assigned: mfinkle)

Tracking

({crash, reproducible})

18 Branch
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox18 affected, firefox20 unaffected)

Details

(Whiteboard: [native-crash], crash signature, URL)

Attachments

(1 attachment, 1 obsolete attachment)

Playing http://yoric.github.com/piranhas/debug.html seems to always crash Fennec after ~1 minute.
Created attachment 692224 [details]
Snapshot of the application

As I am currently actively coding on the application, attaching a snapshot. This is a pure openwebapp, no server involved.
Might be related to bug 812501.
Keywords: crash
See Also: → bug 812501
Whiteboard: [native-crash]
Crash Signature: [@ js::ion::Cannon]
Summary: Reproducible crashes with fennec 18 → Playing Piranhas reproducibly crashes Fennec 18
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox for Android → Core
Summary: Playing Piranhas reproducibly crashes Fennec 18 → Playing Piranhas reproducibly crashes Fennec 18 in js::ion::Cannon
Forgot to mention that I have observed this crash on a Samsung Galaxy Tab 10.1, with Android 4.04.

Updated

5 years ago
Severity: normal → critical
Keywords: reproducible
Hardware: Other → ARM
Version: unspecified → 18 Branch
Same crash with Nightly, http://crash-stats.mozilla.com/report/index/bp-613dd06f-b4e3-419e-b96c-26b8d2121214
Yoric reports setting javascript.options.ion.parallel_compilation to false stops the crash. The fix in bug 819329 did not work completely.
Blocks: 819329
Created attachment 692303 [details] [diff] [review]
patch

This patch simply disables parallel compilation to stop the crashes while a real fix can be made
Assignee: general → mark.finkle
Attachment #692303 - Flags: review?(blassey.bugs)

Comment 7

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #5)
> The fix in bug 819329 did not work completely.
The crash happened in 20.0a1/20121213083934 where the fix of bug 819329 hasn't landed.

Does it happen with 20.0a1/20121214? Which crash signature?

Updated

5 years ago
No longer blocks: 819329
(In reply to Scoobidiver from comment #7)
> (In reply to Mark Finkle (:mfinkle) from comment #5)
> > The fix in bug 819329 did not work completely.
> The crash happened in 20.0a1/20121213083934 where the fix of bug 819329
> hasn't landed.
> 
> Does it happen with 20.0a1/20121214? Which crash signature?

Grr. Yoric said it was an up to date nightly. I guess we need to double check.

Yoric - Can you try updating again? As Scoobidriver says, the fix is on a new nightly.
Yoric - and make sure you reset the javascript.options.ion.parallel_compilation preference
Just upgraded Nightly and reset the option. This seems to remove the crash.
(In reply to David Rajchenbach Teller [:Yoric] from comment #10)
> Just upgraded Nightly and reset the option. This seems to remove the crash.

Thanks for confirming.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819329
(Assignee)

Updated

5 years ago
Attachment #692303 - Attachment is obsolete: true
Attachment #692303 - Flags: review?(blassey.bugs)

Comment 12

5 years ago
This crash still happens in 18.0 Beta and maybe Aurora 19.0 where bug 819329 doesn't exist.
Status: RESOLVED → REOPENED
status-firefox18: --- → affected
status-firefox20: --- → unaffected
Resolution: DUPLICATE → ---

Comment 13

5 years ago
I think it's a dupe of bug 805421.
I saw this crash also in m.google.com; just go to the webpage and leave it alone on the release version 18.0.2

Crash doesn't happen on the nightly when I go there.  I'm guessing it is a dup as well.

Updated

5 years ago
Depends on: 805421
You need to log in before you can comment on or make changes to this bug.