[CONTACTS][DIALER] When making a call from contact details dialer is making strange things: not showing the name of the contact...

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: carlosmartinez, Unassigned)

Tracking

unspecified
x86_64
Windows 7

Firefox Tracking Flags

(blocking-basecamp:-)

Details

Attachments

(2 attachments)

STR:
1-Open contacts app
2-Create a new contact (phone number, email, added to favourites)
3-Open this contact details
4-Place a call from there tapping in the contact phone number

Expected result --> Attention screen is shown with the name of the contact and the rest of the information needed.

Actual result --> See screenshots attached.
Created attachment 692232 [details]
Contact from which you place the call
Created attachment 692233 [details]
Weird outgoing attention screen

Updated

5 years ago
blocking-basecamp: --- → ?
Keywords: qawanted
Triage: BB+, C3, P3 - severe usability issue
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C3 (12dec-1jan)
Unable to reproduce using 12/21 build.

Comment 5

5 years ago
Cannot reproduce it with 12/23 build.
Wait for monitoring.
Mark as BB? for re-triage
blocking-basecamp: + → ?
Triage: BB-, renom if reproduced
blocking-basecamp: ? → -
Priority: P3 → --
Target Milestone: B2G C3 (12dec-1jan) → ---
I can reproduce the lack of a contact name, but not the "artifacts" on the attention screen.  I actually can't see a contact name in almost any context (making a call, receiving a call, receiving an SMS) and I'm still searching for the canonical bug on that specific issue.

Is this issue more about the artifact or about the missing contact name?  I'm guessing it should be one or the other rather than both.
The artifacts are appearing and disappearing, but the lack of a contact name seems like is always there, maybe is a good decision to use this bug to track this problem and if "artifacts" appear again open a new one.
Keywords: qawanted
I still see this problem with Unagi build:
build: 20130506070204
       Gaia : 9377636cee5ac55b9f1d68f598afc7aadfbb2b00
       Gecko : 9c0de2afd22a8476cbfbf891d196ee8640541e75

Reproduce steps:
1. Create a contact with a phone number( the length of the phone number can be from 7 to 11 digits). 
2. Save the contact and make the call from contact
[issue] you will see that the dialer screen does not show contact name.

Updated

4 years ago
Duplicate of this bug: 821390
I'm gonna close this as fixed because the call screen changed a lot and that sounds bad enough that it would be a blocker if it still existed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.