Last Comment Bug 821849 - Android build broken in DataChannel code
: Android build broken in DataChannel code
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: WebRTC: Networking (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla20
Assigned To: Dan Mosedale (:dmose)
: Jason Smith [:jsmith]
Mentors:
Depends on:
Blocks: 806375
  Show dependency treegraph
 
Reported: 2012-12-14 12:31 PST by Dan Mosedale (:dmose)
Modified: 2012-12-16 13:28 PST (History)
2 users (show)
dmose: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Re-apply DeMorgan's law to preprocessor conditions (838 bytes, patch)
2012-12-14 12:31 PST, Dan Mosedale (:dmose)
rjesup: review+
Details | Diff | Splinter Review

Description Dan Mosedale (:dmose) 2012-12-14 12:31:48 PST
Created attachment 692421 [details] [diff] [review]
Re-apply DeMorgan's law to preprocessor conditions

Here's the error:

/Users/dmose/r/inbound/src/netwerk/sctp/datachannel/DataChannel.cpp: In member function 'virtual nsresult mozilla::DataChannelConnectRunnable::Run()':
/Users/dmose/r/inbound/src/netwerk/sctp/datachannel/DataChannel.cpp:397: error: 'struct sockaddr_conn' has no member named 'sconn_len'

In the directory  /Users/dmose/r/inbound/objdir-droid/netwerk/sctp/datachannel
The following command failed to execute properly:

I think there was a race in the creation of the cleanup patch such that when the cleanup patch landed, it regressed a fix for this problem which had landed previously.  Patch for bustage attached.
Comment 1 Dan Mosedale (:dmose) 2012-12-14 12:37:23 PST
Try server build in progress:

 https://tbpl.mozilla.org/?tree=Try&rev=f73d6ea2a425
Comment 2 Dan Mosedale (:dmose) 2012-12-15 10:52:12 PST
Pushed to inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/bb6f5a9bcd27

in-testsuite-, as this is build bustage fixing, so the compiler acts as the test suite.
Comment 3 Ed Morley [:emorley] 2012-12-16 13:11:24 PST
(In reply to Dan Mosedale (:dmose) from comment #2)
> Pushed to inbound:
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/bb6f5a9bcd27
> 
> in-testsuite-, as this is build bustage fixing, so the compiler acts as the
> test suite.

This was mis-posted in bug 821249, because the wrong bug number was in the commit message.

https://hg.mozilla.org/mozilla-central/rev/bb6f5a9bcd27

Note You need to log in before you can comment on or make changes to this bug.