Unable to save mp3 files to device since integrated audio player was added

RESOLVED DUPLICATE of bug 791654

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 791654
5 years ago
2 years ago

People

(Reporter: Scott Garman, Unassigned)

Tracking

17 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121129165506

Steps to reproduce:

I would like to download an mp3 file from zencast.org.

Go to http://zencast.org

Pick one of the direct download links to various mp3 files.





Actual results:

If you simply click on the link, the mp3 file will begin playing in the browser. The browser media player does not appear to offer any option to save the file being played.

Alternately, if you long-press on the direct download mp3 link, there are no options for saving the file to your device. The only options I see are "Open Link in New Tab" (which again plays the file in the browser), "Copy Link", "Share Link", and "Bookmark Link".



Expected results:

I would like some discoverable way to save the file to my device. This was the default behavior which occurred before the media player was added to Firefox for Android.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791654
You need to log in before you can comment on or make changes to this bug.