Closed Bug 821882 Opened 7 years ago Closed 7 years ago

softlink for a plugin not followed

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.14 Branch
x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 754622

People

(Reporter: arto.jaaskelainen, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121129162756

Steps to reproduce:

Oracle Java plugin appears installed in Firefox but SeaMonkey does not find it.


Actual results:

SeaMonkey finds those plugins ok which are directly located into /usr/lib/mozilla/plugins.  For Java plugin (libnpjp2.so) there is a softlink pointing to actual .so file. SeaMonkey does not find actual .so file while Firefox is able to follow the link to actual plugin file destination. 


Expected results:

I expect SeaMonkey to follow softlinks (or a chain of softlinks) to actual destination to load plugin file.
Duplicate of this bug: 812471
Duplicate of this bug: 818192
Sorry for the noise with my incorrect duping...

The SM plugin code is the same as the Firefox one and it should work if it works in Firefox.
Do you have a 32bit system and Firefox is also 32bit as Seamonkey ?
32 bit system, Firefox and SeaMonkey on the very same computer.  
For further testing I created two test links at /usr/lib/mozilla/plugins:

    libflashplayer.so -> /home/my_name/plugins/libflashplayer.so
    libnpjp2.so -> /home/my_name/plugins/libnpjp2.so

Link for Flash plugin is succesful but not link for Java plugin. "about:plugins" shows both in Firefox but only Flash player plugin in SeaMonkey.  That makes me think there is some difference in browser default setup (since plugin loading code is same).
The Java issue is likely ...

DUP Bug 754622 - [linux] Oracle/Sun Java jre1.7.0_04 and later does not work in SeaMonkey

What version of Java are you using?
Previously Oracle JRE 1.7.0_09, now Oracle 1.7.0_10. Yes, this is DUP.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 754622
You need to log in before you can comment on or make changes to this bug.