Fix build warnings in media/mtransport/third_party/nrappkit/src/util/libekr

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: catalinn.iordache, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC] [blocking-webrtc-])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 692473 [details] [diff] [review]
p3v1.patch

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121129151900

Steps to reproduce:

Fixed build warnings in r_assoc.c , r_list.c , r_time.c
(Reporter)

Updated

6 years ago
Hardware: x86 → All
These is third party code and this probably have to be fixed upstream.
Status: UNCONFIRMED → NEW
Component: General → WebRTC: Networking
Ever confirmed: true
QA Contact: jsmith
Attachment #692473 - Flags: review?(ekr)
(Reporter)

Comment 2

6 years ago
is there any chances to get a review+ for this bug?
Comment on attachment 692473 [details] [diff] [review]
p3v1.patch

Review of attachment 692473 [details] [diff] [review]:
-----------------------------------------------------------------

The construct you are changing:
 
if (r = foo()) {


}

is used all over the upstream code. I'm not sure why you're not seeing these warnings
throughout your compile. Regardless, we have opted to suppress the parentheses
warnings for these files rather than do a mass change. See:

https://hg.mozilla.org/mozilla-central/file/bb2f453b7c0f/media/mtransport/third_party/nrappkit/nrappkit.gyp#l154

If you are still seeing these warnings, it is presumably because the suppression
is not working for your platform.
Attachment #692473 - Flags: review?(ekr) → review-
Please report the OS/compiler and version numbers, plus the actual output showing the problem.
Flags: needinfo?(catalinn.iordache)
Whiteboard: [WebRTC] [blocking-webrtc-]
(Reporter)

Comment 5

6 years ago
This were my build warnings:
media/mtransport/third_party/nrappkit/src/util/libekr/r_assoc.c:222:2 [-Wparentheses] suggest parentheses around assignment used as truth value 
media/mtransport/third_party/nrappkit/src/util/libekr/r_assoc.c:273:5 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_assoc.c:295:5 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_assoc.c:348:5 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_assoc.c:393:7 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_list.c:161:5 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_list.c:169:9 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_time.c:201:5 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_time.c:204:13 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_time.c:227:5 [-Wparentheses] suggest parentheses around assignment used as truth value
media/mtransport/third_party/nrappkit/src/util/libekr/r_time.c:230:13 [-Wparentheses] suggest parentheses around assignment used as truth value
Flags: needinfo?(catalinn.iordache)
(Reporter)

Comment 6

6 years ago
I tried to resolved them, building the files with make -C ./obj-[..]/rest of path. I'm using Ubuntu 12.10 3.5.0-19-generic .

I hope this is what you asked me.
(Reporter)

Comment 7

6 years ago
This is one of my first bugs for mozilla code base. I just wanted to resolve something simple for start.
Please also report the compiler and version used. Also, when posting a warning please include the commandline for the file as well (don't use -s in MOZ_MAKE_FLAGS)

Probably the compiler version is a newer version of GCC4.7 that added warnings or changes how they're suppressed.
(Reporter)

Comment 9

6 years ago
gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)
I don't see these same errors when building on Fedora 17 with 4.7.2.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.