crash in nsMsgDatabase::CleanupCache

VERIFIED FIXED in mozilla0.9.1

Status

MailNews Core
Database
P1
critical
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Brade, Assigned: Bienvenu)

Tracking

({crash})

Trunk
mozilla0.9.1
PowerPC
Mac System 9.x
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
With my Mac debug mozilla build from today, I crashed when I was quitting (having 
only a mail 3 pane window open (if that is relevant)).  I had read some e-mail, 
deleted some messages, started to send a message and then canceled it.  On Quit, 
I crashed here:
  nsCOMPtr_base::~nsCOMPtr_base()
  nsMsgDatabase::CleanupCache()+000A0
  nsMsgDBModule::Shutdown()+00024
  nsMsgDBModule::~nsMsgDBModule()+0002C
  nsMsgDBMOdule::Release()
  nsDll::Shutdown()
  nsFreeLibrary
  nsFreeLibraryEnum
  ...


other possibly relevant info:  IMAP, move to trash, nsmail-2
(Reporter)

Updated

17 years ago
Keywords: crash
(Assignee)

Comment 1

17 years ago
Is this reproducible?
(Reporter)

Comment 2

17 years ago
yes, I reproduced it again
(Assignee)

Comment 3

17 years ago
Created attachment 35664 [details] [diff] [review]
proposed fix
(Assignee)

Comment 4

17 years ago
I got an r= from Kathy; can I get an sr= from Seth, and a= from putterman so I
can check this in today? Thanks!

Comment 5

17 years ago
putting in 0.9.1
Keywords: nsbeta1
Priority: -- → P1
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 6

17 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
I'm not sure how to reproduce this.  Kathy when you say you started to send then 
cancel it, did you actually click the Send button?  If so how did you cancel it?
The reason I ask, is that I follow your steps using 2001-05-01 mac build and 
when sending I attach an image so I have time to X close the compose window to 
interrupt the send.  I'm actually stopping the copy to sent folder when I get 
the dialog to Cancel.  I Cancel and then do a File|Quit and crash, but in a 
different place than your crash.  The message sends and I get a copy anyway. I 
will find or log new bugs for what I'm seeing, but I would like to reproduce 
your crash and then verify it.  Also to be sure and since you are familiar with 
the steps you could tell us if it's working for you now. 

Comment 8

17 years ago
FYI...I logged a bug for the new crash 83752 but still would like to know more 
about the steps for this one.
(Reporter)

Comment 9

17 years ago
yes, I think I had pressed send and then canceled that send.  I'm not sure if 
that's relevant or not.

Comment 10

17 years ago
Adding the pref to keep give a send status which provides a cancel button I 
tried this again using original scenario.  No crash.  Verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.