Clearing history from History window brings main window in focus

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 692554 [details]
about support.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121214 Firefox/20.0
Build ID: 20121214030827

Steps to reproduce:

1. Start in safe mode.
2. Open history window ( Nightly->History->Show all history).
3. select a page , right click on it and select "forget about this site"



Actual results:

The main Firefox windows appears on the front/gets focussed.


Expected results:

the history window should be in the front/get focussed UNTIL user closes it, or selects the main firefox window.
WFM for Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121217 Firefox/20.0 (20121217030850). While pressing "forgot about this page" , history windows still get focussed.

Comment 2

5 years ago
WFM with 2012-12-17-03-08-50-mozilla-central-firefox-20.0a1.de.linux-x86_64
(Reporter)

Comment 3

5 years ago
This happens only the first time. If you do the "forget about this site"  again, the hostory page will remain in the front. To repro again, restart the browser and then open history page.


This is reproducible randomly in current profiles and fresh profiles.
When i try to do a screenr, this is *never* reproduced. I suspect this is either a :

1. Windows issue.
2. Related to plugins (not extensions) and dependent on if the site stores some special type of data like cookie, image something something.  I have tried disabling/enabling plugins in various combinations but cant confirm reliably what causes this.
(Reporter)

Comment 4

5 years ago
My list of plugins :
Foxit reader plugin
MS office 2010 14.0.4730.1010
Flash
vlc plugin 2.0.2.0
adobe reader 10.1.4.38
java 7.9
Silverlight 2.1.10411.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:20.0) Gecko/20121214 Firefox/20.0
buildID: (20121214030827)

Works for me on the same build and using STR from comment 0. If someone can reproduce this issue please leave some reliable STR and reopen the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.