Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: xelawafs, Assigned: ferjm)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 692661 [details]
gaia hang sending screen during ussd action

It's still unclear whether the USSD hang happened because the mobile service provider's server took too long to respond or something was up with the phone...So steps to regenerate:

1. Enter a valid USSD code on the dialer for the SIM being used
2. Press call

Expected: USSD code is sent and result is returned by the mobile service provider
Actual: Sending screen appears and persists. Nothing else can be accessed on the phone except the power-off menu

Device/Software Details:
LG Optimus
Build Identifier: 20121207170359
Gaia: Nightly channel
(Reporter)

Updated

6 years ago
Hardware: x86 → ARM
(Assignee)

Comment 1

6 years ago
I am not able to reproduce this issue. I dont have an LG Optimus device to test.. It would be really helpful if you could provide the RIL debug output ( adb logcat -b radio ). 

In any case, I am afraid that the platform does nothing until the RIL notifies back about a successfull or failure delivery of a sent USSD message. It feels like we should have a timeout somewhere to cancel the spinner and let the user retry later.  IIRC there are no timeouts in the Gecko RIL code, so I would say that Gaia is probably the best place to host this timeout.  What do you think Philipp?

We could probably also add a cancelation option in the UX so the user can cancel an USSD request while it is being sent. Marco, do you think that this is something that we should add to the current UX?
Flags: needinfo?(philipp)
(Assignee)

Updated

6 years ago
Flags: needinfo?(marcoc)

Comment 2

6 years ago
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #1)
> 
> We could probably also add a cancelation option in the UX so the user can
> cancel an USSD request while it is being sent. Marco, do you think that this
> is something that we should add to the current UX?

Yes, I agree Fernando. I was able to reproduce this on the Unagi and there is no way of stopping the Sending cycle. 
Do you need a visual for this?
Flags: needinfo?(marcoc)
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #1)
> In any case, I am afraid that the platform does nothing until the RIL
> notifies back about a successfull or failure delivery of a sent USSD
> message. It feels like we should have a timeout somewhere to cancel the
> spinner and let the user retry later.  IIRC there are no timeouts in the
> Gecko RIL code, so I would say that Gaia is probably the best place to host
> this timeout.  What do you think Philipp?

I agree. That or the cancel option that you sugest.
Flags: needinfo?(philipp)
(Assignee)

Comment 4

6 years ago
Thanks Marco and Philipp! I'll ask for tracking-b2g18 since this issue makes the device unusable until reboot.
tracking-b2g18: --- → ?

Comment 5

6 years ago
Tracking due to the fact that the device is unusable until reboot, although this isn't a common user scenario.
tracking-b2g18: ? → +
(Assignee)

Updated

6 years ago
Assignee: nobody → ferjmoreno
(Assignee)

Comment 6

6 years ago
Created attachment 716636 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8243

Pointer to Github pull-request
(Assignee)

Comment 7

6 years ago
Comment on attachment 716636 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8243

Ismael could you take a look at the HTML and CSS changes, please?

Etienne could you check the JS and tests, please?

Thanks!
Attachment #716636 - Flags: review?(igonzaleznicolas)
Attachment #716636 - Flags: review?(etienne)
Attachment #716636 - Flags: review?(igonzaleznicolas) → review+
Comment on attachment 716636 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8243

Thanks this is great!
Attachment #716636 - Flags: review?(etienne) → review+
(Assignee)

Comment 9

6 years ago
Thanks!

https://github.com/mozilla-b2g/gaia/commit/62beab356df3283153b2e849822b820915792a72
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

6 years ago
Comment on attachment 716636 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8243


User impact if declined: No way to cancel an ongoing USSD request with the potential issue of getting stuck in the "Sending" screen.
Testing completed: Manual testing and unit tests added.
Risk to taking this patch (and alternatives if risky): Low risk
String or UUID changes made by this patch: None
Attachment #716636 - Flags: approval-gaia-v1?
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
Attachment #716636 - Flags: approval-gaia-v1? → approval-gaia-v1+
v1-train: 14a6e68
status-b2g18: affected → fixed
You need to log in before you can comment on or make changes to this bug.