Personas/lightweight themes not applied/broken

VERIFIED FIXED in Firefox 19

Status

()

Firefox for Android
Theme and Visual Design
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: aryx, Assigned: sriram)

Tracking

({regression, reproducible})

Trunk
Firefox 20
ARM
Android
regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19 verified, firefox20 verified)

Details

Attachments

(1 attachment)

Firefox for Android 20121216, Android 4.1.2 (stock), Google Nexus S

Starting with build 20121215, installed Personas are not applied anymore (I have https://addons.mozilla.org/firefox/addon/the-wind-blows/ installed).
'Try it on' and 'Keep it' do not apply any theme.
Assignee: nobody → sriram
Status: NEW → ASSIGNED
tracking-fennec: --- → ?
status-firefox20: --- → affected
Keywords: regression, reproducible
(Assignee)

Comment 3

5 years ago
Created attachment 693016 [details] [diff] [review]
Patch

This is the correct null check.
(Sriram is not a good reviewer.. again!)
Attachment #693016 - Flags: review?(mark.finkle)
(Assignee)

Updated

5 years ago
Attachment #693016 - Flags: review?(mark.finkle) → review?(bnicholson)
Attachment #693016 - Flags: review?(bnicholson) → review+

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/167cface3edc
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20

Updated

5 years ago
Blocks: 821434

Updated

5 years ago
Blocks: 821453
(Assignee)

Comment 6

5 years ago
Comment on attachment 693016 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 820868.
User impact if declined: No persona will be seen. Everything will be blocked.
Testing completed (on m-c, etc.): Landed yesterday.
Risk to taking this patch (and alternatives if risky): None. A proper check is added now. (One character change).
String or UUID changes made by this patch: None.
Attachment #693016 - Flags: approval-mozilla-aurora?

Comment 7

5 years ago
Firefox 20.0a1 (2012-11-18)
Device: Galaxy Nexus
OS: Android 4.1.1

Personas (lightweight themes) can be applied now.  Marking bug as VERIFIED FIXED
Status: RESOLVED → VERIFIED
status-firefox20: affected → verified

Comment 8

5 years ago
(In reply to Ioana Chiorean from comment #7)
> Firefox 20.0a1 (2012-11-18)
> Device: Galaxy Nexus
> OS: Android 4.1.1
> 
> Personas (lightweight themes) can be applied now.  Marking bug as VERIFIED
> FIXED

It was Firefox 20.0a1 (2012-11-19)

Updated

5 years ago
Attachment #693016 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox19: --- → fixed

Comment 10

5 years ago
Firefox 19 Beta 1 (2013-01-08)
Device: Galaxy Nexus
OS:Android 4.1.

This was push in beta channel also as Firefox 19 is currently in Beta. As the themes are applied correctly now  I will mark the flag for 19 accordingly as Verified..
status-firefox19: fixed → verified
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.