[Bluetooth] The notification of "Bluetooth received file ready to open" is truncated.

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: iliu, Assigned: iliu)

Tracking

({late-l10n, polish})

unspecified
ARM
Gonk (Firefox OS)
late-l10n, polish

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

Attachments

(6 attachments)

Created attachment 692834 [details]
The notification of "Bluetooth received file ready to open"

STR:
====================
  1. Pair a device and send a file to unagi.
  2. Receive a file by Bluetooth.
  3. Wait the transferring task completely.
  4. See the message of "Bluetooth received file ready to open" in notification center.

Actual:
====================
  The notification of "Bluetooth received file ready to open" is truncated.

Expected:
====================
  The notification of "Bluetooth received file ready to open" should be not truncated.
Created attachment 692836 [details]
The notification of "Bluetooth sending file complete"
Hi Casey,

Regarding the issue, we have discussed for it in mail.
Could you confirm the modification to improve the UX in description?

Received file:
Line1: Bluetooth file received.
Line2: image2002.jpg

Sent file:
Line1: Bluetooth file sent.
Line2: image2002.jpg
Flags: needinfo?(kyee)
blocking-basecamp: ? → -
Keywords: polish

Comment 3

6 years ago
Hi Ian,
This looks fine to me!
Flags: needinfo?(kyee)
Created attachment 694204 [details]
The notification of "Bluetooth received file ready to open" version 12/20
Created attachment 702186 [details]
The notification of "Bluetooth receiving file failed"

Casey,
I miss to consider in case of "sending/receiving file failed".
According the attached screen shot, the sentence is very close to the time stamp(just now). Do you have any suggestion for the case?

In case of sending/receiving file failed:

Received file:
Line1: Bluetooth receiving file failed
Line2: image2002.jpg

Sent file:
Line1: Bluetooth sending file failed
Line2: image2002.jpg
Flags: needinfo?(kyee)
We should also consider other localization.
Keywords: late-l10n

Comment 7

6 years ago
Ian,
Because we already have a icon for Bluetooth we could probably do away with the text.

File receive failure:
[Bluetooth icon]
Line 1: File receive failed.
Line 2: filename.ext

File sent failure:
[Bluetooth icon]
Line 1: File sent failed.
Line 2: filename.ext
Flags: needinfo?(kyee)
Casey,
Thanks for your confirmation.
Let's do away with the text 'Bluetooth' to avoid more truncated issue in different local since having an icon there.

For the file name, we could get unknown file name from Bluetooth API.
If we get a unknown file name, I'll markup the label Line2 with 'Unknown file'.
I summarize the solution again.

Received file:
[Bluetooth icon]
Line1: File received.
Line2: filename.ext

Sent file:
[Bluetooth icon]
Line1: File sent.
Line2: filename.ext

File receive failure:
[Bluetooth icon]
Line 1: File receive failed.
Line 2: filename.ext

File sent failure:
[Bluetooth icon]
Line 1: File sent failed.
Line 2: filename.ext
Created attachment 702658 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7633

Pointer to Github pull-request
Comment on attachment 702658 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7633

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): The string of notification is truncated.
User impact if declined: Cannot see message completely.
Testing completed: Done.
Risk to taking this patch (and alternatives if risky): None.
Attachment #702658 - Flags: review?(l10n)
Attachment #702658 - Flags: review?(ehung)
Attachment #702658 - Flags: approval-gaia-master?(21)
Evelyn and Pike,
Could you please help to review the pr?
Thank you so much!

Comment 12

6 years ago
Comment on attachment 702658 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7633

r=me, only string changes. Thanks.
Attachment #702658 - Flags: review?(ehung) → review+

Comment 13

6 years ago
Comment on attachment 702658 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7633

The strings don't really sound like English, we should get better ones.

Matej, can you help out? Notably, I'm asking about

transferFinished-sentFailed-title=File sent failed.
transferFinished-receivedFailed-title=File received failed.


Maybe something like "Sending file failed." ?
Attachment #702658 - Flags: review?(l10n)
Attachment #702658 - Flags: review-
Attachment #702658 - Flags: feedback?(Mnovak)
I think "Sending file failed" and "Receiving file failed" would work, but it would be even clearer if it said "File could not be sent" and "File could not be received"
Comment on attachment 702658 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7633

Pike and Matej,
I have revised them according your suggestion. And thanks for your reviewing effort. 

transferFinished-sentFailed-title=File could not be sent.
transferFinished-receivedFailed-title=File could not be received.

But we still need to be careful for other locals since the time stamp occupied some width of space.
Attachment #702658 - Flags: review- → review?(l10n)

Comment 16

6 years ago
Comment on attachment 702658 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7633

r=me with one final nit. Mind dropping the '.' at the end of the strings?

I've gone back and forth about it, and then looked at other call sites, which don't end with a '.' as well. At least the alarms and the missed-calls don't.
Attachment #702658 - Flags: review?(l10n)
Attachment #702658 - Flags: review+
Attachment #702658 - Flags: feedback?(Mnovak)
(In reply to Axel Hecht [:Pike] from comment #16)
> Comment on attachment 702658 [details]
> Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7633
> 
> r=me with one final nit. Mind dropping the '.' at the end of the strings?
> 
> I've gone back and forth about it, and then looked at other call sites,
> which don't end with a '.' as well. At least the alarms and the missed-calls
> don't.
Good catch and thanks! I have fixed the final nit.
Wait approval-gaia-master.
I think it's a obvious issue to affect users.
blocking-b2g: --- → tef?

Updated

6 years ago
blocking-b2g: tef? → -
blocking-basecamp: - → ---
tracking-b2g18: --- → +
Please make sure that this does not cause the notification to overlay on top of the timestamp.  This was the reason why it was truncated in portrait view.
https://github.com/mozilla-b2g/gaia/pull/7633
Since the pr is merged, we can close the issue now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Comment on attachment 702658 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7633

Remove flag "approval‑gaia‑v1".
Attachment #702658 - Flags: approval-gaia-v1?(21)
Created attachment 709140 [details]
screenshot

It's still truncated, I believe it's intentionally so...

Do we still want to reopen and fix this?
Flags: needinfo?(iliu)
Nhirata,

I don't see any string 'Bluetooth received file ready to open..' in local file.
(https://github.com/mozilla-b2g/gaia/blob/master/apps/system/locales/system.en-US.properties)
What the build version do you test?
Flags: needinfo?(iliu)
I saw this is fixed in pvt central unagi build.
It now states File sent/File received and didn't get truncated.
Status: RESOLVED → VERIFIED
Uplifted commit 3e01ab512fb36da957af098e48e3800e519f0bf1 as:
v1-train: dacd014b9bf01fed61261c6563ee6a5c34c70633
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.