Closed Bug 822195 Opened 7 years ago Closed 7 years ago

When playing video, the mozAudioChannel changed randomly

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-basecamp:+)

RESOLVED DUPLICATE of bug 819849
B2G C3 (12dec-1jan)
blocking-basecamp +

People

(Reporter: alive, Assigned: baku)

Details

On 12/16 build.
STR:

1. Open video app
2. Play Manifesto

Expected:
Audio channel changed to normal consistently.

Actual:

E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: normal =========
E/GeckoConsole(  468): Content JS LOG at app://system.gaiamobile.org/js/sound_manager.js:35 in anonymous: default =========

It jumps between default and normal channels. I don't open another app for competing. Even so that's strange behavior.

Impact:
We couldn't adjust the volume of video while it's playing.

Not sure if this is bug 816608.
What's the difference between "default" and "normal" channels? I thought that "normal" was the default?
Jason, can you help out with seeing if this is bug 816608 or not?

Andrea, can you take this?
Assignee: nobody → amarchesini
Keywords: qawanted
QA Contact: jsmith
Target Milestone: --- → B2G C3 (12dec-1jan)
(In reply to Jonas Sicking (:sicking) from comment #1)
> What's the difference between "default" and "normal" channels? I thought
> that "normal" was the default?

By spec, default is notification/ringer channel.
Anyway, the event shouldn′t change like this way..
Ah, I think I understand what you are saying. I'm pretty sure this is simply bug 816608
Depends on: 816608
Sorry, I meant bug 819849. I think this is simply a dupe of that so flagging that for now. But we should verify that this bug is fixed once that bug is fixed.
Status: NEW → RESOLVED
Closed: 7 years ago
No longer depends on: 816608
Resolution: --- → DUPLICATE
Duplicate of bug: 819849
blocking-basecamp: ? → +
clean up the qawanted tag
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.